summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-08-29 16:37:24 +0200
committerJim Meyering <meyering@redhat.com>2012-08-30 15:22:00 +0200
commit44547edd7ca7db128df2666fbb3f080f205582db (patch)
treefa7474d52dc79594323df43ec458cb0b699df201 /Makefile.am
parent34e2473f412bfa66d55c969ae1757510e371ea9a (diff)
downloadcoreutils-44547edd7ca7db128df2666fbb3f080f205582db.tar.xz
build: don't use recursive make to build the 'man' subdirectory
* Makefile.am: Include 'man/local.mk'. (SUBDIRS): Remove 'man'. * configure.ac ($MAN): Adjust so that each of its entries has a leading 'man/' component. (AC_CONFIG_FILES): Remove 'man/Makefile'. * man/Makefile.am: Rename ... * man/local.mk: ... like this. With further adjustments: each 'foo.1' target renamed like 'man/foo.1', each '../src/foo.c' dependency as 'src/foo.c', and each '$(srcdir)' usage as '$(srcdir)/man'. Also ... (mandep): Adjust, removing the leading '../' component. Several whitespace adjustments while at it. (ASSORT): Remove, it's already defined in the top-level Makefile.am. * cfg.mk (sc_option_desc_uppercase, sc_man_file_correlation): Remove the associated recipes, they are now directly available from the included 'man/local.mk'. Actually, the other changes in this commit have made these recipes instable and not completely correct, but that will be fixed in later changes.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f80c4a628..d14bf880e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,7 +17,7 @@
ALL_RECURSIVE_TARGETS =
-SUBDIRS = lib src man po tests gnulib-tests
+SUBDIRS = lib src po tests gnulib-tests
changelog_etc = \
ChangeLog-2005 \
@@ -175,3 +175,4 @@ all_programs:
@cd ./src && $(MAKE) -s $@
include $(top_srcdir)/doc/local.mk
+include $(top_srcdir)/man/local.mk