summaryrefslogtreecommitdiff
path: root/qgis-git/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'qgis-git/PKGBUILD')
-rw-r--r--qgis-git/PKGBUILD19
1 files changed, 18 insertions, 1 deletions
diff --git a/qgis-git/PKGBUILD b/qgis-git/PKGBUILD
index 242e52ee6..2114b935f 100644
--- a/qgis-git/PKGBUILD
+++ b/qgis-git/PKGBUILD
@@ -28,7 +28,24 @@ provides=('qgis')
pkgver(){
cd "$_pkgname"
- printf "%s.r%s" "$_pkgver" "$(git rev-list --count $_commit).$(git rev-parse --short $_commit)"
+ printf '%s.r%s.%s' \
+ "$(
+ git archive ${_commit} -- debian/changelog | \
+ tar -Ox | \
+ sed -n '
+ s/^\s*\* Release of \(\S\+\)\s*$/\1/
+ T
+ p
+ ' | \
+ sort -V | \
+ tail -n1
+ )" \
+ "$(
+ git rev-list --count ${_commit}
+ )" \
+ "$(
+ git rev-parse --short ${_commit}
+ )"
}
prepare() {