summaryrefslogtreecommitdiff
path: root/python-pynest2d/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'python-pynest2d/PKGBUILD')
-rw-r--r--python-pynest2d/PKGBUILD14
1 files changed, 13 insertions, 1 deletions
diff --git a/python-pynest2d/PKGBUILD b/python-pynest2d/PKGBUILD
index 3dc39e158..9123d9aeb 100644
--- a/python-pynest2d/PKGBUILD
+++ b/python-pynest2d/PKGBUILD
@@ -8,7 +8,19 @@ pkgdesc="Python bindings for libnest2d"
arch=(x86_64)
url="https://github.com/Ultimaker/pynest2d"
license=("LGPL")
-depends=('python>=3.10' 'python<3.11' polyclipping nlopt)
+_pinned_dependencies=(
+ 'gcc-libs=12.2.0'
+ 'glibc>=2.36'
+ 'nlopt=2.7.1'
+ 'polyclipping=6.4.2'
+)
+depends=(
+ 'python>=3.10'
+ 'python<3.11'
+ 'polyclipping'
+ 'nlopt'
+ "${_pinned_dependencies[@]}"
+)
makedepends=(sip4 cmake boost libnest2d)
source=(${pkgname}-${pkgver}.tar.gz::https://github.com/Ultimaker/pynest2d/archive/${pkgver}.tar.gz)
sha512sums=('67451e3817aa308827683153c9f1fae670d95d393fad3b9b10831f7e255469df3be73fa2f90101c6dbf4034c06b51c4b3d9a4aa242f36325bb943003b0ce1842')