summaryrefslogtreecommitdiff
path: root/python-msal/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'python-msal/PKGBUILD')
-rw-r--r--python-msal/PKGBUILD25
1 files changed, 0 insertions, 25 deletions
diff --git a/python-msal/PKGBUILD b/python-msal/PKGBUILD
deleted file mode 100644
index 1acf46da6..000000000
--- a/python-msal/PKGBUILD
+++ /dev/null
@@ -1,25 +0,0 @@
-# Maintainer: Erich Eckner <arch at eckner dot net>
-# Contributor: Julian Weigt <juw@posteo.de>
-# PKGBUILD generated by pipman, description shortened
-# Python package author: Microsoft Corporation <nugetaad@microsoft.com>
-pkgname=python-msal
-pkgver=1.26.0
-pkgrel=1
-pkgdesc="Microsoft Authentication Library for Python library to access the Microsoft Cloud by supporting authentication of users with Microsoft Azure Active Directory accounts and Microsoft Accounts using OAuth2 and OpenID Connect"
-arch=(any)
-url="https://github.com/AzureAD/microsoft-authentication-library-for-python"
-license=(MIT)
-depends=("python-requests" "python-pyjwt" "python-cryptography" "python-mock")
-makedepends=("python-setuptools")
-source=("$pkgname-$pkgver.tar.gz"::"https://github.com/AzureAD/microsoft-authentication-library-for-python/archive/refs/tags/$pkgver.tar.gz")
-sha512sums=('11611c85b70623fa467e0e101eb2cbcf2f4e552e7b9796d21237c276d008f009e57333ac7c3861d3bdf8bac510a0fbe545671a6ae3a447e4ebb8a198037bebe2')
-
-build() {
- cd "microsoft-authentication-library-for-python-$pkgver"
- python setup.py build
-}
-
-package() {
- cd "microsoft-authentication-library-for-python-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
-}