summaryrefslogtreecommitdiff
path: root/python-azure-core/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'python-azure-core/PKGBUILD')
-rw-r--r--python-azure-core/PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/python-azure-core/PKGBUILD b/python-azure-core/PKGBUILD
new file mode 100644
index 000000000..b16d4a702
--- /dev/null
+++ b/python-azure-core/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Erich Eckner <arch at eckner dot net>
+
+_pkgname=azure-core
+pkgname=python-$_pkgname
+pkgver=1.26.1
+pkgrel=1
+pkgdesc='Microsoft Azure Core Library for Python'
+url='https://pypi.org/project/azure-core/'
+depends=(
+ 'python>=3.10'
+ 'python<3.11'
+ 'python-azure-common'
+)
+makedepends=(
+ 'python-pip'
+ 'python-setuptools')
+checkdepends=(
+ 'python-aiohttp'
+ 'python-trio')
+license=('MIT')
+arch=('i686' 'pentium4' 'x86_64')
+source=("https://files.pythonhosted.org/packages/4f/ec/3ba46ff4deebe738b7213997fc856553282e971a767b6291e05aca9d9566/${_pkgname}-${pkgver}.zip")
+sha512sums=('dcddf28bdbac913e66640adb7c511c74e4597756c444d2ef43fb82d5348eae391544715cbe95600d8caec9afcfe8ab5d20b9b33c49b8fd026b8f0f7657cae931')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build_ext --inplace
+}
+
+check() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py test
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}