summaryrefslogtreecommitdiff
path: root/perl-astro-fits-cfitsio/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'perl-astro-fits-cfitsio/PKGBUILD')
-rw-r--r--perl-astro-fits-cfitsio/PKGBUILD58
1 files changed, 0 insertions, 58 deletions
diff --git a/perl-astro-fits-cfitsio/PKGBUILD b/perl-astro-fits-cfitsio/PKGBUILD
deleted file mode 100644
index 9397113fb..000000000
--- a/perl-astro-fits-cfitsio/PKGBUILD
+++ /dev/null
@@ -1,58 +0,0 @@
-# Maintainer: Erich Eckner <arch at eckner dot net>
-
-pkgname='perl-astro-fits-cfitsio'
-pkgver=1.16
-pkgrel=2
-pkgdesc='Perl extension for using the cfitsio library'
-arch=('i686' 'pentium4' 'x86_64')
-license=('PerlArtistic' 'GPL')
-options=('!emptydirs')
-_pinned_dependencies=(
- 'cfitsio=1:4.2.0'
- 'glibc>=2.31'
-)
-depends=(
- "${_pinned_dependencies[@]}"
- 'perl>=5.36'
- 'perl<5.37')
-makedepends=(
- 'perl-alien-base-wrapper>=1.97'
- 'perl-alien-cfitsio>=4.1.0'
- 'perl-extutils-makemaker>=6.52')
-url='https://metacpan.org/pod/Astro::FITS::CFITSIO'
-_distdir="Astro-FITS-CFITSIO-${pkgver}"
-source=("https://cpan.metacpan.org/authors/id/P/PR/PRATZLAFF/${_distdir}.tar.gz")
-sha512sums=('51d0d6355a243671a105d7637196a4262631fbc60386724952e43d2d97680528011b976101d75ef3ea7f3004118703f9d98488045d78484d8de925e4c92d4c8e')
-
-build() {
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
- PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
-
- cd "$srcdir/$_distdir"
- perl Makefile.PL
- make
- )
-}
-
-check() {
- cd "$srcdir/$_distdir"
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
- make test
- )
-}
-
-package() {
- cd "$srcdir/$_distdir"
- make install
-
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
-}
-
-# Local Variables:
-# mode: shell-script
-# sh-basic-offset: 2
-# End:
-# vim:set ts=2 sw=2 et: