summaryrefslogtreecommitdiff
path: root/perl-alien-wxwidgets/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'perl-alien-wxwidgets/PKGBUILD')
-rw-r--r--perl-alien-wxwidgets/PKGBUILD75
1 files changed, 0 insertions, 75 deletions
diff --git a/perl-alien-wxwidgets/PKGBUILD b/perl-alien-wxwidgets/PKGBUILD
deleted file mode 100644
index 2a16c8975..000000000
--- a/perl-alien-wxwidgets/PKGBUILD
+++ /dev/null
@@ -1,75 +0,0 @@
-# Maintainer: Erich Eckner <arch at eckner dot net>
-# Contributor: Swift Geek <swiftgeek «at» gmail.com>
-# Contributor: Nick Østergaard <oe.nick at gmail dot com>
-# Contributor: John D Jones III (jnbek) <jnbek1972 at gmail dot com>
-
-pkgname=perl-alien-wxwidgets
-_cpan_name=Alien-wxWidgets
-pkgver=0.69
-pkgrel=11
-pkgdesc="building, finding and using wxWidgets binaries"
-arch=('i686' 'pentium4' 'x86_64')
-url="https://metacpan.org/release/${_cpan_name}"
-license=('GPL' 'PerlArtistic')
-provides=(
- 'perl-alien-wxwidgets-utility=0.59')
-depends=(
- 'perl>=5.36'
- 'perl<5.37'
- 'perl-module-pluggable>=2.6'
- 'wxgtk3')
-makedepends=(
- 'perl-extutils-cbuilder>=0.24'
- 'perl-lwp-protocol-https'
- 'perl-module-build>=0.28'
- 'perl-pathtools>=1.50')
-checkdepends=(
- 'perl-test-pod'
- 'perl-test-pod-coverage')
-options=(!emptydirs)
-_distdir="${_cpan_name}-${pkgver}"
-source=("http://www.cpan.org/modules/by-module/${_cpan_name%%-*}/${_distdir}.tar.gz")
-sha512sums=('028eae7fd7f44612b6a56814a38a81681d66a95db5d9e21ffb7ef763ff6c9f68fece8eea4bef0b232546b6e2dd6d7a5c32389b96dd62968c4cb110e6508cd534')
-
-prepare() {
- # Setting these env variables overwrites any command-line-options we don't want...
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
- echo "If build stage tries to pull and compile WX - interrupt as resulting package wont work"
-# warning "If package contains gtk2_3_0_0_uni_gcc_3_4.pm it is an improper package - do not attempt to install it - report in comments instead"
-
-# HAX HAX HAX - hax first in PATH to replace /usr/bin
-# Uncomment lines below to compile against wxgtk2.8
-# mkdir ${srcdir}/hax
-# ln -s /usr/bin/wx-config-2.8 ${srcdir}/hax/wx-config
-# export PATH="${srcdir}/hax:${PATH}"
-### We are now patching issues, so compilation against 3.x is possible
-# https://rt.cpan.org/Public/Bug/Display.html?id=94367
-# https://rt.cpan.org/Public/Bug/Display.html?id=87202
-# {
-# cd "$_distdir"
-# patch < ${srcdir}/wx-config-version-and-env.patch
-# patch ./lib/Alien/wxWidgets/Utility.pm < ${srcdir}/Alien-wxWidgets-0.64-returnor.patch
-# }
-}
-
-build() {
- cd "$_distdir"
- /usr/bin/perl Makefile.PL
- make
-}
-
-check () {
- cd "$_distdir"
- make test
-}
-
-package () {
- cd "$_distdir"
- make install
-
- # remove perllocal.pod and .packlist
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
-}