summaryrefslogtreecommitdiff
path: root/gitstats-git/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'gitstats-git/PKGBUILD')
-rw-r--r--gitstats-git/PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/gitstats-git/PKGBUILD b/gitstats-git/PKGBUILD
index 2d1bf6f3e..e509b484e 100644
--- a/gitstats-git/PKGBUILD
+++ b/gitstats-git/PKGBUILD
@@ -2,20 +2,25 @@
# Contributor: Timo Schmiade <the_isz@gmx.de>
pkgname=gitstats-git
pkgver=294.55c5c28
+_commit="${_pkgver##*.}"
pkgrel=1
pkgdesc="A statistics generator for git repositories."
arch=("any")
url="http://gitstats.sourceforge.net"
license=('GPL3')
depends=('git' 'python2' 'gnuplot')
-source=("git+https://github.com/hoxu/gitstats.git")
+source=("git+https://github.com/hoxu/gitstats.git#commit=${_commit}")
md5sums=("SKIP")
pkgver() {
cd gitstats
printf '%s.%s\n' \
- "$(git rev-list --count master)" \
- "$(git rev-parse --short master)"
+ "$(
+ git rev-list --count "${_commit}"
+ )" \
+ "$(
+ git rev-parse --short "${_commit}"
+ )"
}
package() {