summaryrefslogtreecommitdiff
path: root/sshfp/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <erich.eckner.ext@bestsecret.com>2022-10-18 17:34:15 +0200
committerErich Eckner <erich.eckner.ext@bestsecret.com>2022-10-18 17:34:15 +0200
commit9548d1f967782ce580143ebb2cc1666eee9a8b3b (patch)
treea9abfffc0e64f753c789357743afe020dde6a0b1 /sshfp/PKGBUILD
parent9baae1b1891d73c50f82fbdbd652769e0d3ef7fe (diff)
downloadarchlinuxewe-9548d1f967782ce580143ebb2cc1666eee9a8b3b.tar.xz
sshfp: use python3 (probably won't work without additional patch)
Diffstat (limited to 'sshfp/PKGBUILD')
-rw-r--r--sshfp/PKGBUILD16
1 files changed, 2 insertions, 14 deletions
diff --git a/sshfp/PKGBUILD b/sshfp/PKGBUILD
index 5dea48f0e..ad337dd74 100644
--- a/sshfp/PKGBUILD
+++ b/sshfp/PKGBUILD
@@ -4,31 +4,19 @@
pkgname=sshfp
pkgver=1.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="Generates DNS SSHFP-type records from SSH public keys from public keys from a known_hosts file or from scanning the host's sshd daemon."
arch=('any')
license=('GPL')
-depends=('python2' 'python2-dnspython')
+depends=('python' 'python-dnspython')
url="https://github.com/xelerance/sshfp"
source=("$pkgname-$pkgver.tar.gz::https://github.com/xelerance/$pkgname/archive/${pkgver}.tar.gz")
md5sums=('3cedcc3463e72196ee2028543d03ebfc')
-build() {
- cd "$srcdir"/$pkgname-$pkgver/
-
- # use python2 instead of python
- sed -e 's|python |python2 |g' \
- -i "$srcdir"/$pkgname-$pkgver/Makefile
-}
-
package() {
cd "$srcdir"/$pkgname-$pkgver/
make DESTDIR="$pkgdir" install
-
- sed -e 's|^#!/usr/bin/python$|#!/usr/bin/python2|g' \
- -i "$pkgdir"/usr/bin/sshfp \
- -i "$pkgdir"/usr/bin/dane
}
# vim:set ts=2 sw=2 et: