summaryrefslogtreecommitdiff
path: root/perl-string-format/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <erich.eckner.ext@bestsecret.com>2023-09-15 12:44:45 +0200
committerErich Eckner <erich.eckner.ext@bestsecret.com>2023-09-15 12:44:45 +0200
commit5ac84cfd7a6ea6a55fff5c87d66555b18c2e2400 (patch)
treee2ea7a6303f7001539e45754b97f7aabcc5c4619 /perl-string-format/PKGBUILD
parent35ca51435fc672621286a73c594e597d6eaccd5c (diff)
downloadarchlinuxewe-5ac84cfd7a6ea6a55fff5c87d66555b18c2e2400.tar.xz
remove all unneeded perl-* packages
Diffstat (limited to 'perl-string-format/PKGBUILD')
-rw-r--r--perl-string-format/PKGBUILD69
1 files changed, 0 insertions, 69 deletions
diff --git a/perl-string-format/PKGBUILD b/perl-string-format/PKGBUILD
deleted file mode 100644
index cb4bc63f4..000000000
--- a/perl-string-format/PKGBUILD
+++ /dev/null
@@ -1,69 +0,0 @@
-# Maintainer: Erich Eckner <arch at eckner dot net>
-# Generator : neuesPerlPaket (ef0b8d9e9ed5e7aec93f3e72d031ac7ee7fb4246e042c09b06bbdcecfbc0e3c879d26484951ecde4eb4b299510817c6aead5d93f6a73544b768ed6467f4108fc)
-
-pkgname='perl-string-format'
-pkgver='1.17'
-pkgrel=11
-pkgdesc='sprintf-like string formatting capabilities with arbitrary format definitions'
-arch=('any')
-license=('PerlArtistic' 'GPL')
-options=('!emptydirs')
-depends=(
- 'perl>=5.38'
- 'perl<5.39'
- 'perl-test-simple'
-)
-makedepends=(
- 'perl-extutils-makemaker'
-)
-url='https://metacpan.org/release/String-Format'
-_distdir="String-Format-${pkgver}"
-source=("https://cpan.metacpan.org/authors/id/D/DA/DARREN/${_distdir}.tar.gz")
-sha512sums=('9d003483858d1681d6955b8620cbba649fe8b92c318b29c5dd684857d81320cb35fbb50e537545d1dfd1e3abc9f94acf9263b82442759e55fd686bd6e907a9f6')
-
-build() {
- cd "${srcdir}/${_distdir}"
-
- # Setting these env variables overwrites any command-line-options we don't want...
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='${pkgdir}'" \
- PERL_MB_OPT="--installdirs vendor --destdir '${pkgdir}'" \
- MODULEBUILDRC=/dev/null
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- perl Makefile.PL
- make
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build.PL
- perl Build
- fi
-}
-
-check() {
- cd "${srcdir}/${_distdir}"
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- make test
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build test
- fi
-}
-
-package() {
- cd "${srcdir}/${_distdir}"
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- make install
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build install
- fi
-
- # remove perllocal.pod and .packlist
- find "${pkgdir}" -name .packlist -o -name perllocal.pod -delete
-}