summaryrefslogtreecommitdiff
path: root/perl-module-install-authortests/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <erich.eckner.ext@bestsecret.com>2023-09-15 12:44:45 +0200
committerErich Eckner <erich.eckner.ext@bestsecret.com>2023-09-15 12:44:45 +0200
commit5ac84cfd7a6ea6a55fff5c87d66555b18c2e2400 (patch)
treee2ea7a6303f7001539e45754b97f7aabcc5c4619 /perl-module-install-authortests/PKGBUILD
parent35ca51435fc672621286a73c594e597d6eaccd5c (diff)
downloadarchlinuxewe-5ac84cfd7a6ea6a55fff5c87d66555b18c2e2400.tar.xz
remove all unneeded perl-* packages
Diffstat (limited to 'perl-module-install-authortests/PKGBUILD')
-rw-r--r--perl-module-install-authortests/PKGBUILD66
1 files changed, 0 insertions, 66 deletions
diff --git a/perl-module-install-authortests/PKGBUILD b/perl-module-install-authortests/PKGBUILD
deleted file mode 100644
index d1f1280f6..000000000
--- a/perl-module-install-authortests/PKGBUILD
+++ /dev/null
@@ -1,66 +0,0 @@
-# Maintainer: Erich Eckner <arch at eckner dot net>
-# Generator : neuesPerlPaket (445682a1bd8a70c152ebe76ddf08deb3d21406c80f819873940cb0909a895cfcde52cc62469cd6f4e4d632f24b3df31e0eec78843cb778079f24dc33b18472ea)
-
-pkgname='perl-module-install-authortests'
-pkgver='0.002'
-pkgrel=9
-pkgdesc='designate tests only run by module authors'
-arch=('any')
-license=('PerlArtistic' 'GPL')
-options=('!emptydirs')
-depends=(
- 'perl>=5.38'
- 'perl<5.39'
- 'perl-module-install'
-)
-url='https://metacpan.org/release/Module-Install-AuthorTests'
-_distdir="Module-Install-AuthorTests-${pkgver}"
-source=("https://cpan.metacpan.org/authors/id/R/RJ/RJBS/${_distdir}.tar.gz")
-sha512sums=('13f3c9018171500ec0090f5f634508b3b0b9554fe9b02cf47f008d1e0005358e1b7d65b4b1347c86aff93da6ae60f0e5c1bdcb1f8c01de727231d3481b5b7153')
-
-build() {
- cd "${srcdir}/${_distdir}"
-
- # Setting these env variables overwrites any command-line-options we don't want...
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='${pkgdir}'" \
- PERL_MB_OPT="--installdirs vendor --destdir '${pkgdir}'" \
- MODULEBUILDRC=/dev/null
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- perl Makefile.PL
- make
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build.PL
- perl Build
- fi
-}
-
-check() {
- cd "${srcdir}/${_distdir}"
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- make test
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build test
- fi
-}
-
-package() {
- cd "${srcdir}/${_distdir}"
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- make install
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build install
- fi
-
- # remove perllocal.pod and .packlist
- find "${pkgdir}" -name .packlist -o -name perllocal.pod -delete
-}