summaryrefslogtreecommitdiff
path: root/moc-nosort/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2022-07-06 20:13:20 +0200
committerErich Eckner <git@eckner.net>2022-07-06 20:13:20 +0200
commite3a11ca8f681b90eaf70a92018ef8d1434f14254 (patch)
treeab5a64d70cd153c02311eca1174d5f42513ffd97 /moc-nosort/PKGBUILD
parentba2e41b5db721ba135d1c4c6e5c75c4b9be3ba1c (diff)
downloadarchlinuxewe-e3a11ca8f681b90eaf70a92018ef8d1434f14254.tar.xz
moc-nosort: updates from upstream
Diffstat (limited to 'moc-nosort/PKGBUILD')
-rw-r--r--moc-nosort/PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/moc-nosort/PKGBUILD b/moc-nosort/PKGBUILD
index a01babb03..502c8d03b 100644
--- a/moc-nosort/PKGBUILD
+++ b/moc-nosort/PKGBUILD
@@ -1,4 +1,3 @@
-# $Id$
# Maintainer: Erich Eckner <arch at eckner dot net>
# Contributor: Eric BĂ©langer <eric@archlinux.org>
@@ -10,7 +9,7 @@ pkgrel=27
epoch=1
pkgdesc="An ncurses console audio player designed to be powerful and easy to use"
arch=('i686' 'pentium4' 'x86_64')
-url="http://moc.daper.net/"
+url="https://moc.daper.net/"
license=('GPL')
_pinned_dependencies=(
'gcc-libs=12.1.0'
@@ -20,10 +19,10 @@ _pinned_dependencies=(
'libncursesw.so=6'
'libtool=2.4.7'
)
-depends=("${_pinned_dependencies[@]}")
-makedepends=('speex' 'ffmpeg' 'taglib' 'libmpcdec' 'wavpack' 'libmodplug' 'faad2')
+depends=('libmad' 'libid3tag' 'jack' 'curl' 'libltdl' 'file' "${_pinned_dependencies[@]}")
+makedepends=('speex' 'ffmpeg4.4' 'taglib' 'libmpcdec' 'wavpack' 'libmodplug' 'faad2')
optdepends=('speex: for using the speex plugin'
- 'ffmpeg: for using the ffmpeg plugin'
+ 'ffmpeg4.4: for using the ffmpeg plugin'
'taglib: for using the musepack plugin'
'libmpcdec: for using the musepack plugin'
'wavpack: for using the wavpack plugin'
@@ -31,7 +30,8 @@ optdepends=('speex: for using the speex plugin'
'libmodplug: for using the modplug plugin')
source=(http://ftp.daper.net/pub/soft/moc/stable/${pkgname%-nosort}-${pkgver}.tar.bz2{,.sig}
disable-sort.patch
- moc-ffmpeg4.patch)
+ moc-ffmpeg4.patch
+ moc-https.patch)
sha512sums=('992d06809fb52e58dcee63704bde05795b99edbac46edd8381f314c564490013b18e1853926f419c2c3c7f1bb68ff35e97048de03ace3232b800cf4b3b7dbe0f'
'SKIP'
'7a760eebf22d84f1ac21e3b429c10f7fb77bc8c7642adb57c57c1b6dfb9d2fa464398475778813a803738ec7a6ffee2c3da857bd36a6b89eaf3345ae419dc7ab'
@@ -41,11 +41,13 @@ validpgpkeys=('59359B80406D9E73E80599BEF3121E4F2885A7AA')
prepare() {
cd "${pkgname%-nosort}-${pkgver}"
patch -p0 -i ../moc-ffmpeg4.patch # Fix build with ffmpeg 4
+ patch -p0 -i ../moc-https.patch # Allow https for urls https://moc.daper.net/node/1872
patch -p0 -i ../disable-sort.patch
}
build() {
cd "${pkgname%-nosort}-${pkgver}"
+ export PKG_CONFIG_PATH='/usr/lib/ffmpeg4.4/pkgconfig'
./configure --prefix=/usr --without-rcc \
--with-oss --with-alsa --with-jack --with-aac --with-mp3 \
--with-musepack --with-vorbis --with-flac --with-wavpack \