summaryrefslogtreecommitdiff
path: root/hponcfg/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2024-06-17 21:50:16 +0200
committerErich Eckner <git@eckner.net>2024-06-17 21:57:10 +0200
commite2a4dea3dbd2e1496da68c64d53019ef999ebdb9 (patch)
tree78bc9a1e8bd93ba377c407d9cdcede7cddb06346 /hponcfg/PKGBUILD
parent9f17c182df4b885f289ef58c4405803c04ea1d92 (diff)
downloadarchlinuxewe-e2a4dea3dbd2e1496da68c64d53019ef999ebdb9.tar.xz
hponcfg new
Diffstat (limited to 'hponcfg/PKGBUILD')
-rw-r--r--hponcfg/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/hponcfg/PKGBUILD b/hponcfg/PKGBUILD
new file mode 100644
index 000000000..a77cf4f1f
--- /dev/null
+++ b/hponcfg/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Erich Eckner <arch at eckner dot net>
+# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+
+pkgname=hponcfg
+pkgver=5.6.0_0
+pkgrel=1
+pkgdesc="RILOE II/iLo online configuration utility"
+arch=(x86_64)
+url="https://downloads.linux.hpe.com/SDR/downloads/mcp"
+_pinned_dependencies=(
+ 'glibc>=2.39+r52+gf8e4623421'
+)
+depends=(libxslt "${_pinned_dependencies[@]}")
+groups=(hpproliant)
+license=("CUSTOM")
+source=("https://downloads.linux.hpe.com/SDR/downloads/mcp/centos/8/x86_64/current/$pkgname-${pkgver//_/-}.x86_64.rpm")
+sha256sums=('1cb0d04aba5504a35b5925e262bc0a5a9d7827d3f34075b7f8e9444a19d55f32')
+
+package() {
+ cd "$srcdir"
+ cp -a usr "$pkgdir"
+ cp -a sbin "$pkgdir/usr/bin"
+
+ cd "$pkgdir"/usr
+ mv lib64 lib
+}