summaryrefslogtreecommitdiff
path: root/collectd/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <erich.eckner.ext@bestsecret.com>2024-07-19 16:59:38 +0200
committerErich Eckner <erich.eckner.ext@bestsecret.com>2024-07-19 16:59:38 +0200
commit41309ffd50b7b2c7034c9ac507951de2d11c121a (patch)
tree1b109c2b393e9581fd1f889f2727d06d5a3051da /collectd/PKGBUILD
parent23227c2583d2d7d9bdc7451e93453ee0816af9b9 (diff)
downloadarchlinuxewe-41309ffd50b7b2c7034c9ac507951de2d11c121a.tar.xz
collectd: incorporate upstream fixes
Diffstat (limited to 'collectd/PKGBUILD')
-rw-r--r--collectd/PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/collectd/PKGBUILD b/collectd/PKGBUILD
index 672244e4c..88a4272b5 100644
--- a/collectd/PKGBUILD
+++ b/collectd/PKGBUILD
@@ -85,8 +85,10 @@ _pinned_dependencies=(
depends=("${_pinned_dependencies[@]}" 'libltdl' 'iptables' 'libnsl')
source=("https://storage.googleapis.com/collectd-tarballs/${pkgname}-${pkgver}.tar.bz2"
+ https://github.com/collectd/collectd/commit/623e95394e0e62e7f9ced2104b786d21e9c0bf53.patch
'service')
sha256sums=('5bae043042c19c31f77eb8464e56a01a5454e0b39fa07cf7ad0f1bfc9c3a09d6'
+ '777544cbf803af4d08ea228b29619f8f6e7a4777a85e0fb30693d8240db7246b'
'83957b0b2cc7fa05a4d5f22e6c913ae2b0a4d7821f7b4e2d2e763054cc8c6c21')
backup=('etc/collectd.conf')
@@ -94,20 +96,26 @@ backup=('etc/collectd.conf')
prepare() {
cd ${pkgname}-${pkgver}
sed -i '/sys\/mount.h/d' src/utils/mount/mount.h
+ patch -Np1 < ../623e95394e0e62e7f9ced2104b786d21e9c0bf53.patch
}
build() {
cd ${pkgname}-${pkgver}
+ # fix nut plugin build
+ export CFLAGS="$CFLAGS -Wno-incompatible-pointer-types"
+ # quick fix for https://github.com/collectd/collectd/issues/4310
+ # libgcrypt-config is gone
+ export GCRYPT_CPPFLAGS="$(pkg-config libgcrypt --cflags)"
+ export GCRYPT_LIBS="$(pkg-config libgcrypt --libs)"
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--sbindir=/usr/bin \
--disable-werror \
- --with-python=/usr/bin/python \
--with-perl-bindings='INSTALLDIRS=vendor' \
- make all
+ make all V=1
}
package() {