summaryrefslogtreecommitdiff
path: root/ceph-bin/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <erich.eckner.ext@bestsecret.com>2022-11-06 18:11:30 +0100
committerErich Eckner <erich.eckner.ext@bestsecret.com>2022-11-06 18:11:30 +0100
commit047de8986ccb9779fdc2828410a5205de9975a1a (patch)
tree3c6ee1ab7e6e91aeec907b851dfae48bce2f6fc6 /ceph-bin/PKGBUILD
parent2f72b3f2a517f046eb2e9b32b58aff7197fd3191 (diff)
downloadarchlinuxewe-047de8986ccb9779fdc2828410a5205de9975a1a.tar.xz
ceph-bin: fix more _pinned_dependencies
Diffstat (limited to 'ceph-bin/PKGBUILD')
-rw-r--r--ceph-bin/PKGBUILD21
1 files changed, 19 insertions, 2 deletions
diff --git a/ceph-bin/PKGBUILD b/ceph-bin/PKGBUILD
index a51c89c51..8367c0393 100644
--- a/ceph-bin/PKGBUILD
+++ b/ceph-bin/PKGBUILD
@@ -54,13 +54,28 @@ package_ceph-libs-bin() {
package_ceph-bin() {
_pinned_dependencies=(
+ 'gcc-libs=12.2.0'
+ 'glibc>=2.36'
+ 'libblkid.so=1'
+ 'libcap-ng.so=0'
+ 'libcryptsetup.so=12'
+ 'libcurl.so=4'
+ 'libexpat.so=1'
+ 'libicuuc.so=72'
+ 'libkeyutils.so=1'
+ 'libncursesw.so=6'
+ 'libnl=3.7.0'
+ 'libudev.so=1'
+ 'lz4=1:1.9.4'
+ 'openssl=3.0.7'
+ 'zlib=1:1.2.13'
)
depends=("ceph-libs=${pkgver}-${pkgrel}"
'boost-libs' 'curl' 'fuse3' 'fmt' 'glibc' 'gperftools' 'java-runtime'
'keyutils' 'libaio' 'libutil-linux' 'librdkafka' 'cryptsetup' 'libnl'
'ncurses'
'nss' 'oath-toolkit' 'python'
- 'snappy' 'sudo' 'systemd-libs' 'lua' 'gawk')
+ 'snappy' 'sudo' 'systemd-libs' 'lua' 'gawk' "${_pinned_dependencies[@]}")
optdepends=('smartmontools: disk monitoring via S.M.A.R.T'
'nvme-cli: disk monitoring for NVMe drives')
provides=("ceph=${pkgver}-${pkgrel}")
@@ -73,13 +88,15 @@ package_ceph-bin() {
package_ceph-mgr-bin() {
_pinned_dependencies=(
+ 'gcc-libs=12.2.0'
+ 'glibc>=2.36'
)
depends=("ceph=${pkgver}-${pkgrel}" "ceph-libs=${pkgver}-${pkgrel}"
'bash' 'boost-libs' 'curl' 'gperftools' 'nss' 'fmt'
'python' 'python-cherrypy' 'python-pecan' 'python-pyjwt' 'python-more-itertools'
'python-numpy' 'python-scipy' 'python-six' 'python-coverage' 'python-pytest' 'python-dateutil'
'python-prettytable' 'python-requests' 'python-pyopenssl' 'python-bcrypt' 'python-yaml'
- 'python-werkzeug' 'python-jinja')
+ 'python-werkzeug' 'python-jinja' "${_pinned_dependencies[@]}")
optdepends=('python-influxdb: influx module'
'python-kubernetes: rook module'
'python-prometheus_client: prometheus module'