summaryrefslogtreecommitdiff
path: root/perl-perl-osnames/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'perl-perl-osnames/PKGBUILD')
-rw-r--r--perl-perl-osnames/PKGBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/perl-perl-osnames/PKGBUILD b/perl-perl-osnames/PKGBUILD
index cff877c0..24d1ac99 100644
--- a/perl-perl-osnames/PKGBUILD
+++ b/perl-perl-osnames/PKGBUILD
@@ -18,6 +18,11 @@ makedepends=(
'perl-pathtools'
'perl-test-simple>=0.98'
)
+checkdepends=(
+ 'perl-pod-coverage-trustpod'
+ 'perl-test-pod'
+ 'perl-test-pod-coverage'
+)
url='https://metacpan.org/release/Perl-osnames'
_distdir="Perl-osnames-${pkgver}"
source=("https://cpan.metacpan.org/authors/id/P/PE/PERLANCAR/${_distdir}.tar.gz")
@@ -46,6 +51,8 @@ build() {
check() {
cd "${srcdir}/${_distdir}"
+ export RELEASE_TESTING=1
+
# If using Makefile.PL
if [ -r Makefile.PL ]; then
make test