summaryrefslogtreecommitdiff
path: root/perl-file-countlines/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'perl-file-countlines/PKGBUILD')
-rw-r--r--perl-file-countlines/PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/perl-file-countlines/PKGBUILD b/perl-file-countlines/PKGBUILD
new file mode 100644
index 00000000..4cbeb8af
--- /dev/null
+++ b/perl-file-countlines/PKGBUILD
@@ -0,0 +1,46 @@
+pkgname='perl-file-countlines'
+pkgver='0.0.3'
+pkgrel='1'
+pkgdesc="efficiently count the number of line breaks in a file."
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-perlio-utf8-strict' 'perl-sub-exporter')
+makedepends=()
+url='http://search.mcpan.org/dist/Mixin-Linewise'
+source=("http://search.cpan.org/CPAN/authors/id/M/MO/MORITZ/File-CountLines-v${pkgver}.tar.gz")
+sha512sums=('84adcb4b8ba24f4ea2f23fe4df6da925cdc0f5ff5354a509af50398dfbe58114af7e940f358d4fbcae6acc1af5229e80d0f337d7cbcdaeafb15e856514dcfa41')
+_distdir="File-CountLines-v${pkgver}"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: