summaryrefslogtreecommitdiff
path: root/alpine/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'alpine/PKGBUILD')
-rw-r--r--alpine/PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/alpine/PKGBUILD b/alpine/PKGBUILD
index 6978e47f..257e267e 100644
--- a/alpine/PKGBUILD
+++ b/alpine/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Adrian C. <anrxc..sysphere.org>
pkgname=alpine
-pkgver=2.21.99999.r18.90e12ea
+pkgver=2.21.99999.r20.87e4a6a
_commit=${pkgver##*.}
pkgrel=1
arch=("i686" "pentium4" "x86_64")
@@ -22,15 +22,18 @@ source=(
"alpine::git://repo.or.cz/alpine.git#commit=${_commit}"
'rules.patch'
'topal-patch.patch'
+ 'compilation3.patch'
)
sha512sums=('SKIP'
'b6719c245e5539af07d18b14e4e30e47c8ac1fcd91b431de40e8c0968c09707c1476adb1d322567e0683f28923022aed07291781de055298b49e39d897dbec23'
- 'bdaf9f0ed2bb9d10eaf4b456e24684cd09eb9e97ae2cf6eb4a2bc2bb5e231e8254d79efa63da9918022302fd970180f2dcd90a69d8c8d817c729c6a18fd6d506')
+ 'bdaf9f0ed2bb9d10eaf4b456e24684cd09eb9e97ae2cf6eb4a2bc2bb5e231e8254d79efa63da9918022302fd970180f2dcd90a69d8c8d817c729c6a18fd6d506'
+ '3f5413e0ee83de228b8bd158fe006d68b7e0172df3968cb5db927ba7c257076791b873424e7693140d250d7bf40e4dbdb3bd91fae8f3a9d99e00d88d29c2e6ad')
prepare() {
cd "${srcdir}/${pkgname}"
patch -p1 -i "${srcdir}/topal-patch.patch"
patch -p1 -i "${srcdir}/rules.patch"
+ patch -p1 -i "${srcdir}/compilation3.patch"
}
pkgver() {
@@ -71,7 +74,7 @@ build() {
# Configure Alpine
./configure --prefix=/usr \
--with-passfile=.pine-passfile \
- --without-tcl --disable-shared \
+ --without-tcl \
--with-system-pinerc=/etc/${pkgname}.d/pine.conf \
--with-system-fixed-pinerc=/etc/${pkgname}.d/pine.conf.fixed