summaryrefslogtreecommitdiff
path: root/xraylarch/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2016-04-26 13:56:04 +0200
committerErich Eckner <git@eckner.net>2016-04-26 13:56:04 +0200
commitdceb05de20e6b5459c5eb20e1d45acb595ab59ff (patch)
treeaf4949c59d24039fd8f8d55ef58074b99b39e088 /xraylarch/PKGBUILD
parent565db2208d6c9caaecd59eb76e8679e8eec53286 (diff)
downloadarchlinuxewe.git.save-dceb05de20e6b5459c5eb20e1d45acb595ab59ff.tar.xz
xraylarch dependency update - should work now
Diffstat (limited to 'xraylarch/PKGBUILD')
-rwxr-xr-xxraylarch/PKGBUILD26
1 files changed, 19 insertions, 7 deletions
diff --git a/xraylarch/PKGBUILD b/xraylarch/PKGBUILD
index 7c199a63..101e37ed 100755
--- a/xraylarch/PKGBUILD
+++ b/xraylarch/PKGBUILD
@@ -1,20 +1,28 @@
# Maintainer: Erich Eckner <arch at eckner dot net>
pkgname=xraylarch
pkgver=0.9.27
-pkgrel=2
+pkgrel=3
pkgdesc="Data Analysis Tools for X-ray Spectroscopy"
arch=('any')
url="http://xraypy.github.io/xraylarch/"
license=('BSD')
groups=()
-depends=('python2' 'python2-sqlalchemy' 'python2-scipy' 'python2-matplotlib' 'python2-h5py' 'python2-numpy')
+depends=(
+ 'python2'
+ 'python2-sqlalchemy'
+ 'python2-scipy'
+ 'python2-matplotlib'
+ 'python2-h5py'
+ 'python2-numpy'
+ 'wxpython'
+ 'python2-wxutils'
+ 'python2-wxmplot'
+)
makedepends=()
checkdepends=()
optdepends=(
'python2-termcolor: needed for color-enhanced error messages'
'python2-epics: needed for using the EPICS control system'
- 'python2-wxutils: needed for graphics and plotting'
- 'python2-wxmplot: needed for graphics and plotting'
)
provides=()
conflicts=()
@@ -28,13 +36,17 @@ sha256sums=(
"df85ba8002eda05d388f9564f01881b5ee2ff5eb86c8577c9e35592bc13cc67f"
)
-package() {
+build() {
cd ${pkgname}-${pkgver}
-
# sed "s|DEBUG = False|DEBUG = True|" -i setup.py
-
python2 setup.py build
+
+}
+
+package() {
+
+ cd ${pkgname}-${pkgver}
python2 setup.py install --skip-build --root="${pkgdir}" --prefix=/usr
}