summaryrefslogtreecommitdiff
path: root/qwtplot3d/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-06-24 13:17:18 +0200
committerErich Eckner <git@eckner.net>2019-06-24 13:17:18 +0200
commit99e452289e1db3271652c00eb0321d3bd4589084 (patch)
treed4e826055a756495fc0e5cbac9f82055c15789bd /qwtplot3d/PKGBUILD
parent60929f5f86ca764de092a7bbe867d4f35c5b585f (diff)
downloadarchlinuxewe.git.save-99e452289e1db3271652c00eb0321d3bd4589084.tar.xz
qwtplot3d new
Diffstat (limited to 'qwtplot3d/PKGBUILD')
-rw-r--r--qwtplot3d/PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/qwtplot3d/PKGBUILD b/qwtplot3d/PKGBUILD
new file mode 100644
index 00000000..e6aafdd3
--- /dev/null
+++ b/qwtplot3d/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Erich Eckner <arch at eckner dot net>
+# Contributor: Ronald van Haren <ronald@archlinux.org>
+# Contributor: damir <damir@archlinux.org>
+
+pkgname=qwtplot3d
+pkgver=0.2.7
+pkgrel=10
+pkgdesc="Qt/OpenGL-based C++ programming library containing 3d-widgets"
+arch=('i686' 'pentium4' 'x86_64')
+license=('custom:zlib')
+url="http://qwtplot3d.sourceforge.net/"
+depends=('qt5-base')
+makedepends=('mesa' 'glu')
+source=("https://downloads.sourceforge.net/sourceforge/qwtplot3d/qwtplot3d-$pkgver.tgz"
+ qwtplot3d-gcc44.patch qwtplot3d-qt-4.8.0.patch)
+sha1sums=('4463fafb8420a91825e165da7a296aaabd70abea'
+ '52fa169b651a98550f8a8391ddf52e0eaeb2c215'
+ '8dcafdc9753b0f2eeea2f1e96efa6e8d3d956005')
+
+prepare() {
+ cd ${pkgname}
+ patch -p1 -i "${srcdir}"/qwtplot3d-gcc44.patch
+ patch -p1 -i "${srcdir}"/qwtplot3d-qt-4.8.0.patch
+}
+
+build() {
+ cd ${pkgname}
+ # build qwt:
+ qmake qwtplot3d.pro
+ make
+}
+
+package() {
+ cd ${pkgname}
+
+ # install qwtplot3d: (by hand, because the Makefile do not provide a "install:")
+ install -d "${pkgdir}"/usr/{include/qwtplot3d,lib}
+
+ for n in include/* ; do
+ cp -d $n "${pkgdir}"/usr/include/qwtplot3d
+ done
+
+ for n in lib/libqwtplot3d.so* ; do
+ cp -d $n "${pkgdir}"/usr/lib
+ done
+
+ # install custom license
+ install -Dm644 COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}
+