summaryrefslogtreecommitdiff
path: root/qgis/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2016-09-22 14:23:48 +0200
committerErich Eckner <git@eckner.net>2016-09-22 14:24:47 +0200
commitde43b503e8baa66fd6baa4fc38b886cc89a7893a (patch)
tree7cda278fd68b03aaed0799e7ff998bf180837ca5 /qgis/PKGBUILD
parent1e65e39057537870b24fc9155174567c19b0c282 (diff)
downloadarchlinuxewe.git.save-de43b503e8baa66fd6baa4fc38b886cc89a7893a.tar.xz
qgis neu
Diffstat (limited to 'qgis/PKGBUILD')
-rw-r--r--qgis/PKGBUILD104
1 files changed, 104 insertions, 0 deletions
diff --git a/qgis/PKGBUILD b/qgis/PKGBUILD
new file mode 100644
index 00000000..b69fd4e6
--- /dev/null
+++ b/qgis/PKGBUILD
@@ -0,0 +1,104 @@
+# Maintainer: Erich Eckner <arch at eckner dot net>
+# Contributor: Doug Newgard <scimmia at archlinux dot info>
+# Contributor: XavierCLL <xavier.corredor.llano (a) gmail.com>
+# Contributor: SaultDon <sault.don gmail>
+# Contributor: Lantald < lantald at gmx.com >
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: dibblethewrecker dibblethewrecker.at.jiwe.dot.org
+# Contributor: Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+# Contributor: Eric Forgeot < http://esclinux.tk >
+
+# Globe Plugin and Map Server are disabled in cmake by default.
+# Uncomment them in the build() portion if you'd like them enabled.
+# You will also need to install osgearth-qt4 or fcgi, respectively, before building.
+
+pkgname=qgis
+pkgver=2.16.2
+pkgrel=1
+pkgdesc='Geographic Information System (GIS) that supports vector, raster & database formats'
+url='http://qgis.org/'
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('qca-qt4' 'gdal' 'qwtpolar' 'spatialindex'
+ 'python2-httplib2' 'python2-future' 'python2-qscintilla-qt4' 'python2-sip' 'python2-six')
+makedepends=('cmake' 'gsl' 'perl' 'txt2tags')
+optdepends=('gpsbabel: GPS Tool plugin'
+ 'gsl: Georeferencer plugin'
+ 'python2-jinja: MetaSearch plugin'
+ 'python2-owslib: MetaSearch plugin'
+ 'python2-pygments: MetaSearch plugin'
+ 'python2-psycopg2: DB Manager plugin'
+ 'python2-pygments: DB Manager plugin'
+ 'python2-pyspatialite: DB Manager plugin'
+ 'python2-psycopg2: Processing plugin'
+ 'python2-pyspatialite: Processing plugin'
+ 'python2-yaml: Processing plugin')
+source=("https://qgis.org/downloads/$pkgname-$pkgver.tar.bz2")
+md5sums=('e2a24b2c41af83dcc5b26fcd0e63366b')
+
+prepare() {
+ cd $pkgname-$pkgver
+
+ # Fix references to "python"
+ sed -i 's/\(env \|\/usr\/bin\/\)python$/&2/' $(find . -iname "*.py")
+
+ # Remove mime types already defined by freedesktop.org
+ sed -e '/type="image\/tiff"/,/<\/mime-type>/d' \
+ -e '/type="image\/jpeg"/,/<\/mime-type>/d' \
+ -e '/type="image\/jp2"/,/<\/mime-type>/d' \
+ -e '/type="application\/x-adobe-mif"/,/<\/mime-type>/d' \
+ -i debian/qgis.xml
+
+ [[ -d build ]] || mkdir build
+}
+
+build() {
+ cd $pkgname-$pkgver/build
+
+ cmake -G "Unix Makefiles" ../ \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DQGIS_MANUAL_SUBDIR=share/man \
+ -DENABLE_TESTS=FALSE \
+ -DCMAKE_SKIP_RPATH=TRUE \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DWITH_INTERNAL_QWTPOLAR=FALSE \
+ -DWITH_INTERNAL_{HTTPLIB2,JINJA2,MARKUPSAFE,OWSLIB,PYGMENTS,DATEUTIL,PYTZ,YAML,NOSE2,SIX,FUTURE}=FALSE \
+# -DWITH_SERVER=TRUE \
+# -DWITH_GLOBE=TRUE
+
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver/build
+
+ # Add optional deps based on selected or autodetected options
+ [[ -n "$(sed -n '/^GRASS_PREFIX:/ s/.*=//p' CMakeCache.txt)" ]] && optdepends+=('grass6: GRASS6 plugin')
+ [[ -n "$(sed -n '/^GRASS_PREFIX7:/ s/.*=//p' CMakeCache.txt)" ]] && optdepends+=('grass: GRASS7 plugin')
+ [[ "$(sed -n '/^WITH_SERVER:/ s/.*=//p' CMakeCache.txt)" == "TRUE" ]] && optdepends+=('fcgi: Map Server')
+ [[ "$(sed -n '/^WITH_GLOBE:/ s/.*=//p' CMakeCache.txt)" == "TRUE" ]] && optdepends+=('osgearth-qt4: Globe plugin')
+
+ make DESTDIR="$pkgdir" install
+
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # install desktop files and icons
+ install -Dm644 debian/{qgis,qbrowser}.desktop -t "$pkgdir/usr/share/applications/"
+ for icon in qgis-icon{,-16x16,-60x60} qbrowser-icon{,-60x60}; do
+ local _resolution="${icon##*-}"; [[ "$_resolution" == "icon" ]] && _resolution="512x512"
+ install -Dm644 images/icons/$icon.png "$pkgdir/usr/share/icons/hicolor/$_resolution/apps/${icon%%-*}.png"
+ done
+ for prog in qgis qbrowser; do
+ install -Dm644 images/icons/${prog}_icon.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/$prog.svg"
+ done
+
+ # install mime information and icons
+ install -Dm644 debian/qgis.xml "$pkgdir/usr/share/mime/packages/qgis.xml"
+ install -Dm644 images/icons/qgis-mime-icon.png "$pkgdir/usr/share/icons/hicolor/128x128/mimetypes/qgis-mime.png"
+ for type in asc ddf dem dt0 dxf gml img mime mldata qgs qlr qml qpt shp sqlite; do
+ install -Dm644 images/icons/qgis_${type}_icon.svg "$pkgdir/usr/share/icons/hicolor/scalable/mimetypes/qgis-$type.svg"
+ done
+
+ # compile python files, since the cmake option doesn't seem to account for DESTDIR
+ python2 -m compileall -q "$pkgdir"
+}