summaryrefslogtreecommitdiff
path: root/python2-lmfit/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2016-11-23 06:53:01 +0100
committerErich Eckner <git@eckner.net>2016-11-23 06:54:56 +0100
commitde4682dd94ea100a645e673a9ff6536a8440820f (patch)
tree8f3766c8cd8b8619381ed769e4f2acba156df933 /python2-lmfit/PKGBUILD
parentadc3453235327f29659eb64131420f6b334c126a (diff)
downloadarchlinuxewe.git.save-de4682dd94ea100a645e673a9ff6536a8440820f.tar.xz
python2-lmfit neu
Diffstat (limited to 'python2-lmfit/PKGBUILD')
-rw-r--r--python2-lmfit/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/python2-lmfit/PKGBUILD b/python2-lmfit/PKGBUILD
new file mode 100644
index 00000000..2ca70c2e
--- /dev/null
+++ b/python2-lmfit/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Francois Boulogne <fboulogne at april dot org>
+# Maintainer: Erich Eckner <arch at eckner dot net>
+
+pkgname=python2-lmfit
+pkgver=0.9.3
+pkgrel=1
+pkgdesc="Least-Squares Minimization with Constraints for Python"
+arch=('any')
+url="http://lmfit.github.io/lmfit-py/"
+license=('BSD')
+depends=('python2' 'python2-numpy' 'python2-scipy')
+makedepends=('python2-setuptools')
+checkdepends=('python2-nose')
+source=(https://github.com/lmfit/lmfit-py/archive/${pkgver}.tar.gz)
+
+build() {
+ cd "$srcdir/lmfit-py-$pkgver"
+ python2 setup.py build
+}
+
+check() {
+ cd "$srcdir/lmfit-py-$pkgver"
+ nosetests2 tests
+}
+
+package(){
+ cd "$srcdir/lmfit-py-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:ts=2:sw=2:et:
+md5sums=('440d681d1c4dbc0b8c40ef66cc0300f8')