summaryrefslogtreecommitdiff
path: root/python-wxmplot/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2020-02-24 10:07:31 +0100
committerErich Eckner <git@eckner.net>2020-02-24 10:23:52 +0100
commita7577a8315be644fd19c2e8f98db94df43d1343e (patch)
tree6f1aaced9c5f875e3794d49ac387a31fab0a421a /python-wxmplot/PKGBUILD
parent4a1b33e63eec5ae9ffe3931af5de782e55c8355f (diff)
downloadarchlinuxewe.git.save-a7577a8315be644fd19c2e8f98db94df43d1343e.tar.xz
python-wxmplot: 0.9.40-1 -> 0.9.40-2
Diffstat (limited to 'python-wxmplot/PKGBUILD')
-rwxr-xr-xpython-wxmplot/PKGBUILD65
1 files changed, 12 insertions, 53 deletions
diff --git a/python-wxmplot/PKGBUILD b/python-wxmplot/PKGBUILD
index 0d2f9464..49950636 100755
--- a/python-wxmplot/PKGBUILD
+++ b/python-wxmplot/PKGBUILD
@@ -1,74 +1,33 @@
# Maintainer: Erich Eckner <arch at eckner dot net>
-pkgbase=python-wxmplot
-pkgname=(python2-wxmplot python-wxmplot)
-_pkgname="${pkgbase#*-}"
+pkgname=python-wxmplot
+_pkgname="${pkgname#*-}"
pkgver=0.9.40
-pkgrel=1
+pkgrel=2
pkgdesc='A library for plotting in wxPython using matplotlib'
arch=('any')
url='https://pypi.python.org/pypi/wxmplot/0.9.18'
license=('OSI Approved :: MIT License')
-_deppy2=(
- 'python2>=2.7'
- 'python2<2.8'
- 'python2-wxpython3'
-)
-_deppy=(
+depends=(
'python>=3.8'
'python<3.9'
- 'python-wxpython>=4.0.3'
-)
-_depends=(
'python-matplotlib>=2.0'
'python-numpy>=1.12'
- 'python-six>=1.10')
-_makedepends=(
- 'python-setuptools')
-makedepends=(
- "${_deppy[@]}"
- "${_deppy2[@]}"
- "${_depends[@]}"
- "${_depends[@]/python/python2}"
- "${_makedepends[@]}"
- "${_makedepends[@]/ython/ython2}"
+ 'python-six>=1.10'
+ 'python-wxpython>=4.0.3'
)
+makedepends=(
+ 'python-setuptools')
source=(
"https://pypi.python.org/packages/70/22/21da36326256fc1ce97deafad3b5d8b466d9a73eab7b78cbab542ecb7574/${_pkgname}-${pkgver}.tar.gz"
)
sha512sums=('4edfa801014d6ad7b419e39c97d52ec77c8992b2fc069b2bd81b4fe9c055197bbdf676b273b224e82527a731c89154198ab8e2170df397d14690059b7ea615bf')
-prepare() {
- cp -a ${_pkgname}-${pkgver}{,-py2}
-}
-
build() {
- echo "Building python..."
- (
- cd ${_pkgname}-${pkgver}
- python setup.py build
- )
- echo "Building python2..."
- (
- cd ${_pkgname}-${pkgver}-py2
- python2 setup.py build
- )
-}
-
-package_python2-wxmplot() {
- depends=(
- "${_deppy2[@]}"
- "${_depends[@]/python/python2}"
- )
- cd ${_pkgname}-${pkgver}-py2
- python2 setup.py install --skip-build --root="${pkgdir}" --prefix=/usr
- find "${pkgdir}" -type f -exec sed -si '1 s#[/ ]python\s*$# python2#' {} +
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
}
-package_python-wxmplot() {
- depends=(
- "${_deppy[@]}"
- "${_depends[@]}"
- )
- cd ${_pkgname}-${pkgver}
+package() {
+ cd "${_pkgname}-${pkgver}"
python setup.py install --skip-build --root="${pkgdir}" --prefix=/usr
}