summaryrefslogtreecommitdiff
path: root/python-oauth2/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2017-10-09 14:22:53 +0200
committerErich Eckner <git@eckner.net>2017-10-09 14:22:53 +0200
commitc230628c5373e22902e4684ffb1806c6a0a31210 (patch)
tree4452693a0a6b19d0bf600af1cc8be0d429a85c3b /python-oauth2/PKGBUILD
parent026df1273c827278ff61f1b32645c752a761206a (diff)
downloadarchlinuxewe.git.save-c230628c5373e22902e4684ffb1806c6a0a31210.tar.xz
python-oauth2 neu
Diffstat (limited to 'python-oauth2/PKGBUILD')
-rw-r--r--python-oauth2/PKGBUILD37
1 files changed, 27 insertions, 10 deletions
diff --git a/python-oauth2/PKGBUILD b/python-oauth2/PKGBUILD
index b2477fc5..294159a7 100644
--- a/python-oauth2/PKGBUILD
+++ b/python-oauth2/PKGBUILD
@@ -1,21 +1,38 @@
# Maintainer: Erich Eckner <arch at eckner dot net>
pkgbase=python-oauth2
pkgname=(python-oauth2 python2-oauth2)
-pkgver=1.9
+pkgver=1.0.1
pkgrel=1
-pkgdesc='library for OAuth'
-url='https://pypi.python.org/pypi/oauth2/'
+pkgdesc='framework that aims at making it easy to provide authentication via OAuth 2.0 within an application stack/'
+url='https://github.com/wndhydrnt/python-oauth2/'
arch=('any')
license=('MIT')
-_depends=()
-_optdepends=()
+_depends=(
+ 'python'
+)
+_mdepends=(
+ 'python-mock'
+ 'python-nose'
+ 'python-pymongo'
+ 'python-memcached'
+ 'python-mysql-connector'
+ 'python-redis'
+ 'python-tornado'
+ 'python-setuptools'
+)
+_optdepends=(
+ 'python-memcached'
+ 'python-pymongo'
+ 'python-redis'
+)
makedepends=(
- 'python' 'python2' 'python-setuptools' 'python2-setuptools'
"${_depends[@]}"
"${_depends[@]/python/python2}"
+ "${_mdepends[@]}"
+ "${_mdepends[@]/python/python2}"
)
-source=("https://github.com/joestump/python-oauth2/archive/v${pkgver}.tar.gz")
-sha512sums=('ba3183aa4e5512920fa540955321646c167d23dfd4bc2fad4d5426e1b71e35e91fe11f6cd919a7913015f9bf33c43849659cb97c862a57b5c2e288ace29ad452')
+source=("https://github.com/wndhydrnt/python-oauth2/archive/v${pkgver}.tar.gz")
+sha512sums=('8172289201af844b5570e7e4c678cce1707e4524f20a01d93134b4bff9190fdeab33cc8dd338c00eae78044a5d6d3278d216e083524aefe5819b1d4017c7074b')
prepare() {
cp -a python-oauth2-${pkgver}{,-py2}
@@ -58,7 +75,7 @@ package_python-oauth2() {
cd python-oauth2-${pkgver}
python setup.py install --prefix=/usr --root="${pkgdir}" --skip-build
- install -Dm 644 LICENSE.txt -t "${pkgdir}"/usr/share/licenses/${pkgname}
+ install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}
}
package_python2-oauth2() {
@@ -73,5 +90,5 @@ package_python2-oauth2() {
cd python-oauth2-${pkgver}-py2
python2 setup.py install --prefix=/usr --root="${pkgdir}" --skip-build
- install -Dm 644 LICENSE.txt -t "${pkgdir}"/usr/share/licenses/${pkgname}
+ install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}
}