summaryrefslogtreecommitdiff
path: root/perl-html-formattext-withlinks/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2016-05-20 15:19:43 +0200
committerErich Eckner <git@eckner.net>2016-05-20 15:19:43 +0200
commit94115ddf2bde7f7fff5b518134b3e3ee92d8556c (patch)
tree42a79801541c9a6ce8fa06b73527f6d5df402aa7 /perl-html-formattext-withlinks/PKGBUILD
parent805b26d9c6e0d05fa6502e8095b3291ef3d4bb03 (diff)
downloadarchlinuxewe.git.save-94115ddf2bde7f7fff5b518134b3e3ee92d8556c.tar.xz
perl-html-formattext-withlinks neu
Diffstat (limited to 'perl-html-formattext-withlinks/PKGBUILD')
-rw-r--r--perl-html-formattext-withlinks/PKGBUILD72
1 files changed, 72 insertions, 0 deletions
diff --git a/perl-html-formattext-withlinks/PKGBUILD b/perl-html-formattext-withlinks/PKGBUILD
new file mode 100644
index 00000000..bb466b89
--- /dev/null
+++ b/perl-html-formattext-withlinks/PKGBUILD
@@ -0,0 +1,72 @@
+# Maintainer: Erich Eckner <arch at eckner dot net>
+# Generator : neuesPerlPaket (5872fdbe767f20dd006eece094815303adfcd3b336cb5ad02d10742b82e6f11e31530fef3b41a2af59678d729daebff83cde847dab68d62647f62cf8dc586685)
+
+pkgname='perl-html-formattext-withlinks'
+pkgver='0.15'
+pkgrel='1'
+pkgdesc='HTML to text conversion with links as footnotes'
+arch=('x86_64' 'i686')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+provides=(
+ 'perl-html-formattext-withlinks')
+depends=(
+ 'perl-html-formattext>=2'
+ 'perl-html-tree'
+ 'perl-uri')
+makedepends=(
+ 'perl-test-simple'
+ 'perl-module-build>=0.38')
+checkdepends=(
+ 'perl-test-mockobject')
+url='https://metacpan.org/release/HTML-FormatText-WithLinks'
+_distdir="HTML-FormatText-WithLinks-${pkgver}"
+source=("https://cpan.metacpan.org/authors/id/S/ST/STRUAN/${_distdir}.tar.gz")
+sha512sums=('cdec4ba94c3f9dfd4e9c8b03be0e24068b23b634499bce062e0b281b26ad3a0288c0d4cc35b4db62fd81ad5f0a0f9ce42a59478af10a81ca2f5901ab79cdf550')
+
+build() {
+ cd "${srcdir}/${_distdir}"
+
+ # Setting these env variables overwrites any command-line-options we don't want...
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='${pkgdir}'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '${pkgdir}'" \
+ MODULEBUILDRC=/dev/null
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ perl Makefile.PL
+ make
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build.PL
+ perl Build
+ fi
+}
+
+check() {
+ cd "${srcdir}/${_distdir}"
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make test
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build test
+ fi
+}
+
+package() {
+ cd "${srcdir}/${_distdir}"
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make install
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build install
+ fi
+
+ # remove perllocal.pod and .packlist
+ find "${pkgdir}" -name .packlist -o -name perllocal.pod -delete
+}