summaryrefslogtreecommitdiff
path: root/lilypond-devel/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2016-11-22 11:09:56 +0100
committerErich Eckner <git@eckner.net>2016-11-22 12:29:51 +0100
commitc5d36d17b696e77783a4b6a12df38d7bb3d564d7 (patch)
tree2016d0022473f74f8fe6d2371b1e62b7d026d112 /lilypond-devel/PKGBUILD
parent2578371c153340c0bc555bc9c3c82ef1e4bca368 (diff)
downloadarchlinuxewe.git.save-c5d36d17b696e77783a4b6a12df38d7bb3d564d7.tar.xz
lilypond-devel neu
Diffstat (limited to 'lilypond-devel/PKGBUILD')
-rw-r--r--lilypond-devel/PKGBUILD73
1 files changed, 73 insertions, 0 deletions
diff --git a/lilypond-devel/PKGBUILD b/lilypond-devel/PKGBUILD
new file mode 100644
index 00000000..6207b4e3
--- /dev/null
+++ b/lilypond-devel/PKGBUILD
@@ -0,0 +1,73 @@
+# Contributor: Patrick McCarty <pnorcks at gmail dot com>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+# Maintainer: Erich Eckner <arch at eckner dot net>
+
+pkgname=lilypond-devel
+pkgver=2.19.51
+pkgrel=1
+pkgdesc="An automated music engraving system (development version)"
+arch=('i686' 'x86_64')
+url="http://lilypond.org/"
+license=('GPL')
+depends=('fontconfig'
+ 'freetype2'
+ 'guile1.8'
+ 'pango'
+ 'glib2'
+ 'python2')
+makedepends=('fontforge'
+ 'gsfonts'
+ 't1utils'
+ 'ghostscript'
+ 'texlive-core>=2011.23170'
+ 'tex-gyre-fonts'
+)
+optdepends=('netpbm: building HTML documentation'
+ 'imagemagick: building HTML documentation'
+ 'ttf-kochi-substitute: building HTML documentation'
+ 'texi2html>=1.82: building HTML documentation'
+ 'rsync: installing HTML documentation')
+provides=("lilypond=$pkgver")
+conflicts=('lilypond' 'lilypond-git')
+source=("http://download.linuxaudio.org/lilypond/sources/v2.19/lilypond-${pkgver}.tar.gz" 'no_fontforge-versioncheck.patch')
+sha256sums=('81163eccaeee083681b93b727eed00ed93f57899df9d423aba76f5e800db92ac'
+ 'e74391f718babb984c5f637397162cf096c4716f5b9a21346ec76035cfc80817')
+
+prepare() {
+ cd "$srcdir/lilypond-$pkgver"
+
+ # python2 fix
+ for file in $(find . -name '*.py' -print); do
+ sed -i 's_^#!.*/usr/bin/python_#!/usr/bin/python2_' $file
+ sed -i 's_^#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
+ done
+
+ patch -Np1 < $srcdir/no_fontforge-versioncheck.patch
+ rm -rf python/out/
+}
+
+build() {
+ cd "$srcdir/lilypond-$pkgver"
+
+ export GUILE=/usr/bin/guile
+ export GUILE_CONFIG=/usr/bin/guile-config
+ export PYTHON="python2"
+ export PYTHON_CONFIG="python2-config"
+ export GUILE=/usr/bin/guile1.8
+ export GUILE_CONFIG=/usr/bin/guile-config1.8
+
+ ./autogen.sh --prefix=/usr \
+ --disable-documentation
+
+ # FIXME: the extra LDFLAG should not be needed;
+ # this is a regression somewhere
+ make LDFLAGS+=" -pthread" all
+}
+
+package() {
+ cd "$srcdir/lilypond-$pkgver"
+ make DESTDIR="$pkgdir/" \
+ vimdir="/usr/share/vim/vimfiles" install
+
+ rm -rf "$pkgdir/usr/share/man"
+}