summaryrefslogtreecommitdiff
path: root/archiso-cross/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2020-01-15 12:06:26 +0100
committerErich Eckner <git@eckner.net>2020-01-15 12:06:26 +0100
commite408ee230267dadf0d9ef67e1cb1241b454b3502 (patch)
treec41e114fb61bfec95cf0bc891c79146b09bbf3ab /archiso-cross/PKGBUILD
parent5a331c29f0cb5308f0cd7dc2fabe9044a98adc72 (diff)
downloadarchlinuxewe.git.save-e408ee230267dadf0d9ef67e1cb1241b454b3502.tar.xz
archiso-cross: fix pkgname
Diffstat (limited to 'archiso-cross/PKGBUILD')
-rw-r--r--archiso-cross/PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/archiso-cross/PKGBUILD b/archiso-cross/PKGBUILD
index c46e640d..c50551b8 100644
--- a/archiso-cross/PKGBUILD
+++ b/archiso-cross/PKGBUILD
@@ -2,16 +2,19 @@
# Contributor: Gerardo Exequiel Pozzi <djgera@archlinux.org>
# Contributor: Pierre Schmitz <pierre@archlinux.de>
-pkgname=archiso
+pkgname=archiso-cross
+_pkgname="${pkgname%-*}"
pkgver=43
-pkgrel=1
+pkgrel=2
+conflicts=(archiso)
+provides=("archiso=${pkgver}")
pkgdesc='Tools for creating Arch Linux live and install iso images - modified to make cross compiling easier'
arch=('any')
license=('GPL')
url='https://projects.archlinux.org/archiso.git/'
depends=('make' 'arch-install-scripts' 'squashfs-tools' 'libisoburn' 'dosfstools' 'lynx')
-source=("https://sources.archlinux.org/other/${pkgname}/${pkgname}-${pkgver}.tar.gz"
- "https://sources.archlinux.org/other/${pkgname}/${pkgname}-${pkgver}.tar.gz.sig"
+source=("https://sources.archlinux.org/other/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
+ "https://sources.archlinux.org/other/${_pkgname}/${_pkgname}-${pkgver}.tar.gz.sig"
'default-arch-value.patch')
sha256sums=('4d2274cc5f1c48883941c3e37dfe7882632f9c455f97635aa079c1812571cb13'
'SKIP'
@@ -20,10 +23,10 @@ validpgpkeys=('0F334D8698881578F65D2AE55ED514A45BD5C938' # Gerardo Exequiel Poz
'4AA4767BBC9C4B1D18AE28B77F2D434B9741E8AC') # Pierre Schmitz
prepare() {
- cd "${pkgname}-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
patch -p1 -i "${srcdir}/default-arch-value.patch"
}
package() {
- make -C "${pkgname}-${pkgver}" DESTDIR="${pkgdir}" install
+ make -C "${_pkgname}-${pkgver}" DESTDIR="${pkgdir}" install
}