summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEduardo Chappa <chappa@washington.edu>2022-06-04 01:28:26 -0600
committerEduardo Chappa <chappa@washington.edu>2022-06-04 01:28:26 -0600
commitf95e2d179774739a885468144e68de047245ada5 (patch)
tree99e044d3ee7c6c308f80ca8e887ebbbea1e1d471 /configure.ac
parent9726c098a739edfdca6218bc5dee104c310957e9 (diff)
downloadalpine-f95e2d179774739a885468144e68de047245ada5.tar.xz
* If kerberos is not fully installed remove it from the list of libraries.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4fa94f16..de5ecb57 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1684,6 +1684,7 @@ AC_SUBST([C_CLIENT_BUNDLED], $alpine_c_client_bundled)
dnl provide KRB5 support?
if test "x$alpine_GSSTYPE" != "xnone" ; then
+ OLDLIB="$LIBS"
AC_SEARCH_LIBS(gss_init_sec_context,gss gssapi gssapi_krb5,
[
dnl MIT-based?
@@ -1693,6 +1694,7 @@ if test "x$alpine_GSSTYPE" != "xnone" ; then
if test ! -d /usr/kerberos/include ; then
alpine_GSSTYPE="none"
alpine_gss_none_reason="header files not found"
+ LIBS="$OLDLIBS"
fi
])
],