summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEduardo Chappa <chappa@washington.edu>2021-04-17 21:46:47 -0600
committerEduardo Chappa <chappa@washington.edu>2021-04-17 22:03:56 -0600
commitd2ad22272baf7d977d6dac930d149af0cd8982c9 (patch)
tree659005f73de6d966a7444b9ebce8084fadb7f6ba /configure.ac
parentf6519aa1448e62a757d43e57cabd081ab594dfb1 (diff)
downloadalpine-d2ad22272baf7d977d6dac930d149af0cd8982c9.tar.xz
* Add new type SUINT32, as a shorter version of UINT32 for systems that
do not have a proper uint32_t type. SUINT32 is defined by default to be UINT32, but during compilation the user can define an environment variable SUINT32 to be, say, unsigned long, and that will make SUINT32 to take that type. This, and the source codem, are the only places where this is documented. Work in collaboration with professor Martin Trusler.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0c2d9c7..00421c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1935,6 +1935,12 @@ AC_CHECK_HEADERS([stdint.h], [uint32=uint32_t], [
])
AC_DEFINE_UNQUOTED([UINT32], $uint32, [System defined unsigned 32 bit integer])
+if test -z "$SUINT32" ; then
+ SUINT32="$uint32"
+fi
+
+AC_DEFINE_UNQUOTED([SUINT32], $SUINT32, [System defined for shorter than unsigned 32 bit integer])
+
AC_CACHE_CHECK(argument pointer type of qsort compare function and base,
ac_cv_func_qsort_argtype,
[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[