summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEduardo Chappa <chappa@washington.edu>2015-02-28 15:59:56 -0700
committerEduardo Chappa <chappa@washington.edu>2015-02-28 15:59:56 -0700
commitc2af1608456087b5d9475e3b288a12554214c221 (patch)
tree6b691ebc599503249ebc0cf697eb35f2bacf5c98 /configure.ac
parent4db5ba9a511564e4a3cb3d2b67bce4bb171eae4f (diff)
downloadalpine-c2af1608456087b5d9475e3b288a12554214c221.tar.xz
* new version 2.20.2
* Further enhancement to the configure script in finding the location of the SSL include and library files, when they are installed in th e default location by openssl. * When Alpine sends an attachment, it will set the boundary attribute in lower case, as some SMTP servers, such as those of libero.it reject messages if the boundary attribute is in uppercase. * Alpine fails to remove temporary files used during a display or sending filter. Fix contributed by Phil Brooke. * SMIME: Crash when checking the signature of a message that contains a RFC822 attached message. Reported by Holger Trapp and Bjorn Krellner.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 23 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index ab83a4a..272144e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,7 +15,7 @@ dnl */
AC_PREREQ([2.69])
-AC_REVISION([Rev:16 by chappa@washington.edu])
+AC_REVISION([Rev:17 by chappa@washington.edu])
dnl Alpine Version Number is in $srcdir/VERSION
AC_INIT([alpine],[m4_normalize(m4_include(VERSION))],[chappa@washington.edu])
@@ -720,6 +720,8 @@ dnl When the system has openssl installed in its default location
dnl instead of the one used by the distribution assume that this
dnl is the one intended to be used.
alpine_SSLDIR="/usr/local/ssl"
+ alpine_SSLINCLUDE="$alpine_SSLDIR/include"
+ alpine_SSLLIB="$alpine_SSLDIR/lib"
else
dnl preload c-client default locations/options
case $host in
@@ -869,7 +871,9 @@ dnl find it anywhere else.
alpine_SSLDIR="/usr/local/ssl"
;;
esac
+fi
+if test "x$alpine_SSLTYPE" != "xnone" ; then
AC_ARG_WITH(ssl-dir,
AS_HELP_STRING([--with-ssl-dir=DIR],[Root of SSL lib/include path]),
[
@@ -903,9 +907,7 @@ dnl find it anywhere else.
alpine_SSLLIB=$withval
fi
])
-fi
-if test "x$alpine_SSLTYPE" != "xnone" ; then
dnl setup globals so tests below work
if test -n "$alpine_SSLINCLUDE" ; then
CPPFLAGS="-I$alpine_SSLINCLUDE $CPPFLAGS"
@@ -1874,18 +1876,26 @@ else
fi
fi
- if test ! -f ${certdir}/factory.pem ; then
- AC_MSG_NOTICE([* * * SSL file "${certdir}/factory.pem" is missing.])
- AC_MSG_NOTICE([* * * This might indicate that CA certs did not get properly])
- AC_MSG_NOTICE([* * * installed. If you get certificate validation failures])
- AC_MSG_NOTICE([* * * in Alpine, this might be the reason for them.])
- fi
+ SSL_CERT_LINK="no"
if test -z "`ls ${certdir} | $EGREP '^@<:@0-9A-Fa-f@:>@{8}\.@<:@0-9@:>@'`" ; then
- AC_MSG_NOTICE([* * * No 8-hexdigit symlinks in certificate directory "${certdir}".])
- AC_MSG_NOTICE([* * * This might indicate that CA certs did not get properly])
- AC_MSG_NOTICE([* * * installed. If you get certificate validation failures])
- AC_MSG_NOTICE([* * * in Alpine, this might be the reason for them.])
+ SSL_BUNDLE_EXISTS="no"
+ SSL_PEM="factory.pem ca-bundle.pem"
+ for SSL_BUNDLE in $SSL_PEM
+ do
+ if test -f ${certdir}/${SSL_BUNDLE} ; then
+ SSL_BUNDLE_EXISTS="yes"
+ fi
+ done
+ else
+ SSL_CERT_LINK="yes"
+ fi
+
+ if test "x$SSL_BUNDLE_EXISTS" = "xno" -a "x$SSL_CERT_LINK" = "xno" ; then
+ AC_MSG_NOTICE([* * * No certificates found in "${certdir}".])
+ AC_MSG_NOTICE([* * * This might indicate that CA certs did not get properly])
+ AC_MSG_NOTICE([* * * installed. If you get certificate validation failures])
+ AC_MSG_NOTICE([* * * in Alpine, this might be the reason for them.])
fi
if test -n "$alpine_SSLINCLUDE" ; then