summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEduardo Chappa <chappa@washington.edu>2019-01-26 09:16:38 -0700
committerEduardo Chappa <chappa@washington.edu>2019-01-26 09:16:38 -0700
commitb21e2fe446ea9400c8184d6509cf67418857ab09 (patch)
treef75393999c03c936f03da99dc0f833af1587a937 /configure.ac
parent7959dcd9075d7c9369a0c0843927a489780319bb (diff)
downloadalpine-b21e2fe446ea9400c8184d6509cf67418857ab09.tar.xz
* Add --with-tcl-lib-dir=PATH option to the configure script, in
case the TCL libraries are not located in a standard path. Also add ca-root-nss.crt to the list of bundles to test for existence of certificates. Based on a report in comp.mail.pine by Roderick.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e9f1e85..f9e149c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,7 +15,7 @@ dnl */
AC_PREREQ([2.69])
-AC_REVISION([Rev:26 by chappa@washington.edu])
+AC_REVISION([Rev:27 by chappa@washington.edu])
dnl Alpine Version Number is in $srcdir/VERSION
AC_INIT([alpine],[m4_esyscmd(tr -d \\n < VERSION)],[chappa@washington.edu])
@@ -1058,6 +1058,16 @@ if test "x$with_tcl" = "xno" ; then
WEB_BUILD=
AC_MSG_NOTICE([Excluding TCL Support, and thus Web Alpine Support])
else
+ AC_ARG_WITH(tcl-lib-dir,
+ AS_HELP_STRING([--with-tcl-lib-dir=PATH],[Specific TCL Librar dir, like \"/usr/opt/tcl86/lib\"]),
+ [
+ if test "x$withval" != "xno" ; then
+ alpine_TCLLIBDIR=$withval
+ if test -n "$alpine_TCLLIBDIR" ; then
+ LDFLAGS="-L$alpine_TCLLIBDIR $LDFLAGS"
+ fi
+ fi
+ ])
AC_ARG_WITH(tcl-lib,
AS_HELP_STRING([--with-tcl-lib=LIBRARY],[Specific TCL Library, like \"tcl8.6\"]),
[
@@ -1986,7 +1996,7 @@ else
SSL_CERT_LINK="no"
if test -z "`ls ${certdir} | $EGREP '^@<:@0-9A-Fa-f@:>@{8}\.@<:@0-9@:>@'`" ; then
SSL_BUNDLE_EXISTS="no"
- SSL_PEM="factory.pem ca-bundle.pem ca-bundle.crt"
+ SSL_PEM="factory.pem ca-bundle.pem ca-bundle.crt ca-root-nss.crt"
for SSL_BUNDLE in $SSL_PEM
do
if test -f ${certdir}/${SSL_BUNDLE} ; then