summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEduardo Chappa <chappa@washington.edu>2015-07-26 08:29:05 -0600
committerEduardo Chappa <chappa@washington.edu>2015-07-26 08:29:05 -0600
commit7c946bfafe961c1dda51d19b5c29a5600ef1e5ec (patch)
tree608ff1bdeafce3223747418560cb39e045a5683f /configure.ac
parent9306e227fc7b1b096d4a58f8c06da66603a50a6a (diff)
downloadalpine-7c946bfafe961c1dda51d19b5c29a5600ef1e5ec.tar.xz
* Fix compilation error in arg.c when pwdcertdir was being freed, even
though a password file might have not been defined. * Work on reducing the number of warnings in OSX.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 1 insertions, 34 deletions
diff --git a/configure.ac b/configure.ac
index f4cf950..ba9ba20 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1412,7 +1412,7 @@ if test "$alpine_with_ldap" = "yes" ; then
[
LIBS="$LIBS -llber"
])
- AC_SEARCH_LIBS(ldap_init,ldap,
+ AC_SEARCH_LIBS(ldap_initialize,ldap,
[
alpine_has_ldap=yes
],
@@ -1427,39 +1427,6 @@ if test "$alpine_with_ldap" = "yes" ; then
AC_MSG_NOTICE([* * * Including LDAP Support])
AC_DEFINE([ENABLE_LDAP], [], [Enable LDAP query support])
fi
- dnl we use deprecated functions (ldap_get_values)
- dnl OpenLDAP 2.3.x doesn't define LDAP_DEPRECATED by default like 2.2.x
-dnl AC_MSG_CHECKING([if we should define LDAP_DEPRECATED])
-dnl AC_RUN_IFELSE(
-dnl [AC_LANG_SOURCE([[
-dnl #include <stdio.h>
-dnl #include <stdlib.h>
-dnl #include <ldap.h>
-dnl int main(void) {
-dnl
-dnl if (LDAP_VENDOR_VERSION >= 20300)
-dnl exit(0);
-dnl
-dnl exit(2);
-dnl }
-dnl ]])],
-dnl [
-dnl AC_MSG_RESULT(yes)
-dnl AC_DEFINE(LDAP_DEPRECATED, 1,
-dnl [Define if you use OpenLDAP 2.3.x deprecated functions])
-dnl
-dnl ],
-dnl [
-dnl AC_MSG_RESULT(no)
-dnl ],
-dnl [
-dnl AC_MSG_WARN([cross compiling: not checking])
-dnl ]
-dnl )
-dnl
-dnl else
-dnl AC_MSG_NOTICE([Cannot find LDAP functions! Excluding LDAP support.])
-dnl fi
fi
dnl PAM support is needed to build c-client in some linux, and hence Alpine.