summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEduardo Chappa <chappa@washington.edu>2013-08-04 22:05:02 -0600
committerEduardo Chappa <chappa@washington.edu>2013-08-04 22:05:02 -0600
commit68e60cfaa434ab6fa738949cca151b2d28252025 (patch)
treec1c3576af7b76b0d7db488c6ea58b8f2868f060a /configure.ac
parent82ec113957d8297ed08c51c20cbc4b0a6f623d4e (diff)
downloadalpine-68e60cfaa434ab6fa738949cca151b2d28252025.tar.xz
* Set minimum version of Openssl to 1.0.1c.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 42ec7b41..dbfdcc37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1030,14 +1030,14 @@ if test "x$alpine_SSLTYPE" != "xnone" ; then
[
LIBS="$LIBS -lssl"
- AC_MSG_CHECKING([Openssl library version >= 1.0])
+ AC_MSG_CHECKING([Openssl library version >= 1.0.0c])
AC_RUN_IFELSE(
[AC_LANG_SOURCE([[
#include <stdio.h>
#include <openssl/ssl.h>
int main(void) {
- if (OPENSSL_VERSION_NUMBER >= 0x1000105fL)
+ if (OPENSSL_VERSION_NUMBER >= 0x1000003f)
exit(0);
exit(2);
@@ -1047,7 +1047,7 @@ int main(void) {
AC_MSG_RESULT(yes)
],
[
- AC_MSG_ERROR(Install openssl version >= 1.0.1e)
+ AC_MSG_ERROR(Install openssl version >= 1.0.1c)
exit 1
],
[