summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEduardo Chappa <chappa@washington.edu>2017-09-29 23:51:00 -0600
committerEduardo Chappa <chappa@washington.edu>2017-09-29 23:51:00 -0600
commit4681adf1bb1d0a1313706d7d96a3ef930ebe5fd9 (patch)
treea0d1bfd05325921860e7578a54b7b4afb3112262 /configure.ac
parent4ef47e8fa6934d003434f3a37875d0abb98636d8 (diff)
downloadalpine-4681adf1bb1d0a1313706d7d96a3ef930ebe5fd9.tar.xz
* NTLM authentication support with the ntlm library, in Unix systems.
Based on code provided by Maciej W. Rozycki.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac48
1 files changed, 45 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 8c06f87..8266684 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,7 +15,7 @@ dnl */
AC_PREREQ([2.69])
-AC_REVISION([Rev:21 by chappa@washington.edu])
+AC_REVISION([Rev:23 by chappa@washington.edu])
dnl Alpine Version Number is in $srcdir/VERSION
AC_INIT([alpine],[m4_normalize(m4_include(VERSION))],[chappa@washington.edu])
@@ -31,7 +31,7 @@ AC_CANONICAL_HOST
AC_LANG(C)
-AC_MSG_NOTICE([Configuring for $PACKAGE_STRING ($host))])
+AC_MSG_NOTICE([Configuring for $PACKAGE_STRING ($host)])
# start out with intent to build Web Alpine
WEB_BUILD=web/src/alpined.d
@@ -1584,6 +1584,38 @@ if test "x$alpine_GSSTYPE" != "xnone" ; then
fi
fi
+dnl Include NTLM?
+AC_ARG_WITH(ntlm,
+ AC_HELP_STRING([--without-ntlm],[Disable NTLM client support]),
+ [with_ntlm=$withval])
+
+dnl provide NTLM support?
+if test "x$with_ntlm" = "xno" ; then
+ alpine_NTLM="none"
+else
+ alpine_NTLM=
+
+ AC_SEARCH_LIBS(buildSmbNtlmAuthRequest, ntlm,
+ [
+ AC_CHECK_HEADER([ntlm.h],
+ [
+ extra_auth_ntlm=ntl
+ AC_MSG_NOTICE([including NTLM support])
+ ],
+ [
+ alpine_NTLM="none"
+ alpine_ntlm_none_reason="header file ntlm.h not found"
+ ])
+ ],
+ [
+ alpine_NTLM="none"
+ alpine_ntlm_none_reason="ntlm library not found"
+ ])
+ if test -n "$alpine_ntlm_none_reason" ; then
+ AC_MSG_NOTICE([NOT including NTLM Support: $alpine_ntlm_none_reason])
+ fi
+fi
+
dnl check for tcl libraries for Web Alpine (HACKY)
if test -n "$WEB_BUILD" ; then
TCL_VERSIONS_DOT="tcl8.6 tcl8.5 tcl8.4 tcl8.3"
@@ -1985,11 +2017,18 @@ else
fi
fi
+extra_auth_gss=
if test "x$alpine_GSSTYPE" != "xnone" ; then
- c_client_specials="${c_client_specials}EXTRAAUTHENTICATORS=gss "
+ extra_auth_gss=gss
AC_MSG_NOTICE([* * * Including Kerberos5 functionality])
fi
+extra_auth_ntlm=
+if test "x$alpine_NTLM" != "xnone" ; then
+ extra_auth_ntlm=ntl
+ AC_MSG_NOTICE([* * * Including NTLM Authenticator])
+fi
+
if test -n "$CPPFLAGS" ; then
alpine_c_client_cflags="$alpine_c_client_cflags ${CPPFLAGS}"
fi
@@ -2016,6 +2055,9 @@ if test -n "$alpine_c_client_gccoptlevel" ; then
AC_SUBST(C_CLIENT_GCCOPTLEVEL, GCCOPTLEVEL=\"$alpine_c_client_gccoptlevel\")
fi
+c_client_auths="$extra_auth_gss $extra_auth_ntlm"
+AC_SUBST([C_CLIENT_AUTHS], $c_client_auths)
+
AC_SUBST([C_CLIENT_SPECIALS], $c_client_specials)
dnl Deal with Web Alpine