summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEduardo Chappa <chappa@washington.edu>2014-06-20 23:23:19 -0600
committerEduardo Chappa <chappa@washington.edu>2014-06-20 23:23:19 -0600
commit121a42f3d82c1b98c384857960d14b2057a95c41 (patch)
tree3dbd271cc59b33cee35acd5a3dd55a997c7848bc /configure.ac
parent60b67de2ba4be4d2bfeeeea685869e9a5a7363c0 (diff)
downloadalpine-121a42f3d82c1b98c384857960d14b2057a95c41.tar.xz
* new version 2.19.9992
* Alpine would not parse options from the command line, such as -patterns-filters2, correctly. * Add /usr/local/include as a path to find include and libs files for openssl in FreeBSD. * Management certificate screen now prints, in addition to the e-mail address of the owner of the certificates, the dates of validity and the MD5 hash of such certificates. * crash when processing message/rfc822 attachments that are encoded in base64. * Openssl: if /usr/local/ssl exists, assume that this is the intended place where ssl libraries, include files and certificates are located. Typically, distributions do not use this directory, so its existence indicates that Openssl has been specially installed there, so it is probably a preferred place to get the system Openssl files. * Postponed messages whose content-type is text/html, text/enriched and text/richtext are sent with that content-type, even though, after resuming composition, Alpine had changed its type to text/plain. * HTML: <BR>, <BR />, and <BR/&> are considered the same inline tag; the same is valid for the <HR> tag.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 672a0bdb..5796364f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -715,6 +715,11 @@ AC_ARG_WITH(ssl,
if test "x$with_ssl" = "xno" ; then
alpine_SSLTYPE="none"
+elif test -d /usr/local/ssl ; then
+dnl When the system has openssl installed in its default location
+dnl instead of the one used by the distribution assume that this
+dnl is the one intended to be used.
+ alpine_SSLDIR="/usr/local/ssl"
else
dnl preload c-client default locations/options
case $host in
@@ -787,6 +792,8 @@ dnl find it anywhere else.
alpine_SSLLIB="/sw/lib"
alpine_SSLCERTS="/sw/etc/ssl/certs"
alpine_SSLKEYS="/sw/etc/ssl/private"
+ elif test -d /usr/local/ssl ; then
+ alpine_SSLDIR="/usr/local/ssl"
elif test -d /System/Library/OpenSSL ; then
alpine_SSLDIR="/System/Library/OpenSSL"
alpine_SSLCERTS="$alpine_SSLDIR/certs"
@@ -818,8 +825,13 @@ dnl find it anywhere else.
alpine_SSLDIR="/etc/ssl"
alpine_SSLCERTS="$alpine_SSLDIR/certs"
alpine_SSLKEYS="$alpine_SSLDIR/private"
- alpine_SSLINCLUDE="/usr/include/openssl"
- alpine_SSLLIB="/usr/lib"
+ if test -d /usr/local/include/openssl ; then
+ alpine_SSLINCLUDE="/usr/local/include/openssl"
+ alpine_SSLLIB="/usr/local/lib"
+ else
+ alpine_SSLINCLUDE="/usr/include/openssl"
+ alpine_SSLLIB="/usr/lib"
+ fi
;;
*-*-openbsd*)
alpine_SSLDIR="/etc/ssl"