summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEduardo Chappa <chappa@washington.edu>2016-08-26 16:31:10 -0600
committerEduardo Chappa <chappa@washington.edu>2016-08-26 16:31:10 -0600
commit0556fa1fb3098640340b10ebe045600531336581 (patch)
treeba5e996cb0bf78bd651d9241c1c98903961a6940 /configure.ac
parent77df61fa95f641b7e8124caa802dd8011e5c5567 (diff)
downloadalpine-0556fa1fb3098640340b10ebe045600531336581.tar.xz
* Add improvements to the Solaris port to find openssl files and compile
without problems.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2418aab..94b062d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -854,7 +854,9 @@ dnl find it anywhere else.
alpine_SSLDIR="/usr/local/ssl"
;;
*-*-solaris*)
- if test -d /usr/sfw/include/openssl ; then
+ if test -d /usr/include/openssl ; then
+ alpine_SSLINCLUDE="/usr/include/openssl"
+ elif test -d /usr/sfw/include/openssl ; then
alpine_SSLDIR="/usr/sfw"
elif test -d /opt/csw/include/openssl ; then
alpine_SSLDIR="/opt/csw"
@@ -1154,6 +1156,7 @@ case "$host" in
if test x$GCC = "xyes" ; then
systype="GSO"
alpine_c_client_target="gso"
+ CFLAGS="$CFLAGS -D__USE_LEGACY_PROTOTYPES__"
else
systype="SOC"
alpine_c_client_target="soc"