summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEduardo Chappa <chappa@washington.edu>2017-12-02 13:14:20 -0700
committerEduardo Chappa <chappa@washington.edu>2017-12-02 13:14:20 -0700
commit04458e1f15f6e50d03325a89d30eeb63d90ff6c3 (patch)
treeee2c03d2c3e7ba8cad121830b13376aab38b8c40 /configure.ac
parent0f9fea5d15563bb92c376aede610a5e7bc677ac8 (diff)
downloadalpine-04458e1f15f6e50d03325a89d30eeb63d90ff6c3.tar.xz
* Add /usr/local to add automatic support for ldap in Freebsd,
in case the user has ldap installed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 22 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 5a391d82..cc4392b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,7 +15,7 @@ dnl */
AC_PREREQ([2.69])
-AC_REVISION([Rev:25 by chappa@washington.edu])
+AC_REVISION([Rev:26 by chappa@washington.edu])
dnl Alpine Version Number is in $srcdir/VERSION
AC_INIT([alpine],[m4_esyscmd(tr -d \\n < VERSION)],[chappa@washington.edu])
@@ -1000,13 +1000,23 @@ if test "x$with_ldap" = "xno" ; then
else
dnl Do stuff to figure out where OpenLDAP is
+ case $host in
+ *-*-freebsd*)
+ alpine_LDAPDIR="/usr/local"
+ alpine_LDAPINCLUDE="${LDAPDIR}/include"
+ alpine_LDAPLIB="${LDAPDIR}/lib"
+ ;;
+ esac;
+
alpine_with_ldap=yes
+
AC_ARG_WITH(ldap-dir,
AS_HELP_STRING([--with-ldap-dir=DIR],[Root of LDAP lib/include path]),
[
if test "x$withval" != "xno" ; then
- CPPFLAGS="$CPPFLAGS -I${withval}/include"
- LDFLAGS="$LDFLAGS -L${withval}/lib"
+ alpine_LDAPDIR="${withval}"
+ alpine_LDAPINCLUDE="${LDAPDIR}/include"
+ alpine_LDAPLIB="${LDAPDIR}/lib"
fi
])
@@ -1014,7 +1024,7 @@ else
AS_HELP_STRING([--with-ldap-include-dir=DIR],[Directory containing LDAP include files]),
[
if test "x$withval" != "xno" ; then
- CPPFLAGS="$CPPFLAGS -I$withval"
+ alpine_LDAPINCLUDE="$withval"
fi
])
@@ -1022,9 +1032,16 @@ else
AS_HELP_STRING([--with-ldap-lib-dir=DIR],[LDAP library path]),
[
if test "x$withval" != "xno" ; then
- LDFLAGS="$LDFLAGS -L$withval"
+ alpine_LDAPLIB="${withval}"
fi
])
+
+ if test -n "$alpine_LDAPINCLUDE" ; then
+ CPPFLAGS="$CPPFLAGS -I${alpine_LDAPINCLUDE}/include"
+ fi
+ if test -n "$alpine_LDAPLIB" ; then
+ LDFLAGS="$LDFLAGS -L${alpine_LDAPLIB}/lib"
+ fi
fi
dnl Include SMIME?