# set manually sysctl vm.mmap_min_addr=0 before building this package

# Parallel builds lead to "virtual memory exhausted"?
# not sure, if still needed (or in fact, working)
eval "$(
  declare -f build | \
    sed '
      s|kmk|kmk -j 1|
    ';
)"

# let's not use too much memory, gcc tmpfiles can in this
# case also be put on a real /tmp (instead of tmpfs) to reduce
# preasure on the RAM
eval "$(
  declare -f build | \
    sed '
      /source/ i \ sed -i 's/-pipe//g' Config.kmk
    '
)"