summaryrefslogtreecommitdiff
path: root/extra/nasm/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/nasm/PKGBUILD')
-rw-r--r--extra/nasm/PKGBUILD25
1 files changed, 9 insertions, 16 deletions
diff --git a/extra/nasm/PKGBUILD b/extra/nasm/PKGBUILD
index f644e426..220091bd 100644
--- a/extra/nasm/PKGBUILD
+++ b/extra/nasm/PKGBUILD
@@ -1,20 +1,13 @@
+# see FS#60380
+source+=('0001-Remove-invalid-pure_func-qualifiers.patch')
+sha1sums+=('b853817a1dd5dc902b36ae80d11402d68e6d9a44')
+prepare() {
+ cd $pkgname-$pkgver
+ patch -Np1 -i "$srcdir/0001-Remove-invalid-pure_func-qualifiers.patch"
+}
+
# i486-specific
if [ "${CARCH}" = "i486" ]; then
- # remove all fonts and ghostscript (we don't build the manual)
- makedepends=(${makedepends[@]//perl-font-ttf/})
- makedepends=(${makedepends[@]//perl-sort-versions/})
- makedepends=(${makedepends[@]//fontconfig/})
- makedepends=(${makedepends[@]//adobe-source-sans-pro-fonts/})
+ # remove ttf-liberation (X packages missing for installing the font)
makedepends=(${makedepends[@]//ttf-liberation/})
- makedepends=(${makedepends[@]//ghostscript/})
-
- eval "$(
- declare -f build | \
- sed '
- /make .*doc/d
- '
- )"
fi
-
-# orginal download link unstable
-#sed -i 's@http://www.nasm.us/pub/nasm/releasebuilds/${pkgver}/${pkgname}-${pkgver}.tar.xz@https://ftp.osuosl.org/pub/blfs/conglomeration/${pkgname}/${pkgname}-${pkgver}.tar.xz@' PKGBUILD