summaryrefslogtreecommitdiff
path: root/extra/librsvg/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/librsvg/PKGBUILD')
-rw-r--r--extra/librsvg/PKGBUILD15
1 files changed, 14 insertions, 1 deletions
diff --git a/extra/librsvg/PKGBUILD b/extra/librsvg/PKGBUILD
index f4a8b595..833cc0bb 100644
--- a/extra/librsvg/PKGBUILD
+++ b/extra/librsvg/PKGBUILD
@@ -3,7 +3,7 @@
eval "$(
declare -f prepare | \
sed '
- /autogen.sh/ i sed -i \"s/\\\$(CARGO) build/RUSTFLAGS=\\"-C target-cpu=pentium3\\" \\\$(CARGO) build/g\" Makefile.am
+ /autogen.sh/ i sed -i \"s/\\\$(CARGO).* build/RUSTFLAGS=\\"-C target-cpu=pentium3 -C target-feature=-sse2\\" \\0/g\" Makefile.am
'
)"
@@ -23,3 +23,16 @@ eval "$(
s/make check/make check || true/
'
)"
+
+# use rust, not rustup, compiled rustc uses pentium3, non-SSE2 optimizations,
+# no clue what we get with rustup!
+
+makedepends=(${makedepends[@]//rustup/})
+makedepends+=('rust')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ s/rustup/#rustup/
+ '
+)"