summaryrefslogtreecommitdiff
path: root/core/glib2/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/glib2/PKGBUILD')
-rw-r--r--core/glib2/PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/core/glib2/PKGBUILD b/core/glib2/PKGBUILD
index ae229167..27be5242 100644
--- a/core/glib2/PKGBUILD
+++ b/core/glib2/PKGBUILD
@@ -1,6 +1,17 @@
+eval "$(
+ declare -f package_glib2 | \
+ sed '
+ 2 a arch=(i486 i686 pentium3 x86_64)
+ '
+ declare -f package_glib2-docs | \
+ sed '
+ 2 a arch=(any)
+ '
+)"
+
# i486-specific
if [ "${CARCH}" = "i486" ]; then
- # no documentation
+ # documentation is not built by i486 slave
makedepends=(${makedepends[@]//gtk-doc/})
eval "$(
declare -f build | \
@@ -16,8 +27,6 @@ if [ "${CARCH}" = "i486" ]; then
'
)"
- pkgname=(${pkgname[@]//glib2-docs})
-
# all but one test succeed, for now disable testing
# ERROR: timer - too few tests run (expected 7, got 0)
# ERROR: timer - exited with status 134 (terminated by signal 6?)