summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-05-03 10:58:19 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2018-05-03 10:58:19 +0200
commit79e7e2495c4e4d8336d9d8640149da7bfa9f1aa6 (patch)
tree537d3988fdf9677cbd1f2a02320a51147bd68298
parentdb116f344d936411b1648e39f50226dbbab6b930 (diff)
parent7ffe1a68efb230c3692bfdcf50366ab3397225ea (diff)
downloadpackages-79e7e2495c4e4d8336d9d8640149da7bfa9f1aa6.tar.xz
Merge branch 'master' of github.com:archlinux32/packages
-rw-r--r--community/libnids/PKGBUILD2
-rw-r--r--community/libnids/libnids-1.24-inline.patch92
-rw-r--r--community/python-tqdm/PKGBUILD11
-rw-r--r--community/python-tqdm/tqdm-4.22.0-sleep-test-workaround.patch12
-rw-r--r--extra/python-beaker/PKGBUILD12
5 files changed, 82 insertions, 47 deletions
diff --git a/community/libnids/PKGBUILD b/community/libnids/PKGBUILD
index 7be0ea3e..13578e05 100644
--- a/community/libnids/PKGBUILD
+++ b/community/libnids/PKGBUILD
@@ -3,7 +3,7 @@
# see https://src.fedoraproject.org/cgit/rpms/libnids.git/commit/?id=ecafb692f20e0acad555f66c3cc1646997a82dae
source+=('libnids-1.24-inline.patch')
-sha256sums+=('0c2b0426a6bab56641f3579dca266ea8d38e1834230154a1be9bbe2f66e2df5e')
+sha256sums+=('3aea2351877c2a789d753ac66f1323a3d575dead9fb04c559e221dbebdfc7e3e')
prepare() {
cd $pkgname-$pkgver
diff --git a/community/libnids/libnids-1.24-inline.patch b/community/libnids/libnids-1.24-inline.patch
index 000c69bc..b17b73e9 100644
--- a/community/libnids/libnids-1.24-inline.patch
+++ b/community/libnids/libnids-1.24-inline.patch
@@ -1,46 +1,46 @@
-diff --git a/libnids-1.24-inline.patch b/libnids-1.24-inline.patch
-new file mode 100644
-index 0000000..e3a6cce
---- /dev/null
-+++ b/libnids-1.24-inline.patch
-@@ -0,0 +1,40 @@
-+Patch by Robert Scheck <robert@fedoraproject.org> for libnids <= 1.24 which
-+avoids making the functions ip_fast_csum, ip_compute_csum, my_tcp_check and
-+my_udp_check inline, see https://github.com/aol/moloch/issues/440 as well.
-+
-+--- libnids-1.24/src/checksum.c 2010-02-26 11:58:41.000000000 +0100
-++++ libnids-1.24/src/checksum.c.inline 2016-02-09 14:08:38.000000000 +0100
-+@@ -120,7 +120,7 @@
-+ By Jorge Cwik <jorge@laser.satlink.net>, adapted for linux by Arnt
-+ Gulbrandsen.
-+ */
-+-inline u_short ip_fast_csum(u_char * iph, u_int ihl)
-++u_short ip_fast_csum(u_char * iph, u_int ihl)
-+ {
-+ u_int sum;
-+ if (dontchksum(((struct ip*)iph)->ip_src.s_addr))
-+@@ -191,13 +191,13 @@
-+ this routine is used for miscellaneous IP-like checksums, mainly in
-+ icmp.c
-+ */
-+-inline u_short
-++u_short
-+ ip_compute_csum(u_char * buff, int len)
-+ {
-+ return (csum_fold(csum_partial(buff, len, 0)));
-+ }
-+
-+-inline u_short
-++u_short
-+ my_tcp_check(struct tcphdr *th, int len, u_int saddr, u_int daddr)
-+ {
-+ if (dontchksum(saddr))
-+@@ -205,7 +205,7 @@
-+ return csum_tcpudp_magic(saddr, daddr, len, IPPROTO_TCP,
-+ csum_partial((u_char *)th, len, 0));
-+ }
-+-inline u_short
-++u_short
-+ my_udp_check(void *u, int len, u_int saddr, u_int daddr)
-+ {
-+ if (dontchksum(saddr))
+diff -rauN libnids-1.24/src/checksum.c libnids-1.24-inline-patch/src/checksum.c
+--- libnids-1.24/src/checksum.c 2010-02-26 11:58:41.000000000 +0100
++++ libnids-1.24-inline-patch/src/checksum.c 2018-05-03 07:53:10.552320792 +0200
+@@ -120,7 +120,7 @@
+ By Jorge Cwik <jorge@laser.satlink.net>, adapted for linux by Arnt
+ Gulbrandsen.
+ */
+-inline u_short ip_fast_csum(u_char * iph, u_int ihl)
++u_short ip_fast_csum(u_char * iph, u_int ihl)
+ {
+ u_int sum;
+ if (dontchksum(((struct ip*)iph)->ip_src.s_addr))
+@@ -172,7 +172,7 @@
+ computes the checksum of the TCP/UDP pseudo-header
+ returns a 16-bit checksum, already complemented
+ */
+-static inline u_short
++static u_short
+ csum_tcpudp_magic(u_int saddr, u_int daddr, u_short len,
+ u_short proto, u_int sum)
+ {
+@@ -191,13 +191,13 @@
+ this routine is used for miscellaneous IP-like checksums, mainly in
+ icmp.c
+ */
+-inline u_short
++u_short
+ ip_compute_csum(u_char * buff, int len)
+ {
+ return (csum_fold(csum_partial(buff, len, 0)));
+ }
+
+-inline u_short
++u_short
+ my_tcp_check(struct tcphdr *th, int len, u_int saddr, u_int daddr)
+ {
+ if (dontchksum(saddr))
+@@ -205,7 +205,7 @@
+ return csum_tcpudp_magic(saddr, daddr, len, IPPROTO_TCP,
+ csum_partial((u_char *)th, len, 0));
+ }
+-inline u_short
++u_short
+ my_udp_check(void *u, int len, u_int saddr, u_int daddr)
+ {
+ if (dontchksum(saddr))
diff --git a/community/python-tqdm/PKGBUILD b/community/python-tqdm/PKGBUILD
new file mode 100644
index 00000000..b7329924
--- /dev/null
+++ b/community/python-tqdm/PKGBUILD
@@ -0,0 +1,11 @@
+# https://github.com/tqdm/tqdm/issues/538
+
+source+=('tqdm-4.22.0-sleep-test-workaround.patch')
+sha512sums+=('ac09e7578ad380f55f9371a067061bd1f23be6a799ec82c3abf2471d7d780bd435b423d0ab1f989cf7039b467d5adfa38e324cb887b0b27f52218fa3753956fa')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ /cp/ i pushd ${srcdir}/tqdm-$pkgver && patch -Np1 -i "${srcdir}"/tqdm-4.22.0-sleep-test-workaround.patch && popd
+ '
+)"
diff --git a/community/python-tqdm/tqdm-4.22.0-sleep-test-workaround.patch b/community/python-tqdm/tqdm-4.22.0-sleep-test-workaround.patch
new file mode 100644
index 00000000..ac9caae3
--- /dev/null
+++ b/community/python-tqdm/tqdm-4.22.0-sleep-test-workaround.patch
@@ -0,0 +1,12 @@
+diff -rauN tqdm-4.22.0/tqdm/tests/tests_synchronisation.py tqdm-4.22.0-sleep-test-workaround-patch/tqdm/tests/tests_synchronisation.py
+--- tqdm-4.22.0/tqdm/tests/tests_synchronisation.py 2018-04-12 01:27:25.000000000 +0200
++++ tqdm-4.22.0-sleep-test-workaround-patch/tqdm/tests/tests_synchronisation.py 2018-05-03 08:42:28.204036417 +0200
+@@ -155,7 +155,7 @@
+ timeend = timer.time()
+ while not (t1.monitor.woken >= timeend and t1.miniters == 1):
+ timer.sleep(1)
+- sleep(0.000001)
++ sleep(0.001)
+ assert t1.miniters == 1 # check that monitor corrected miniters
+ assert t2.miniters == 500 # check that t2 was not adjusted
+
diff --git a/extra/python-beaker/PKGBUILD b/extra/python-beaker/PKGBUILD
new file mode 100644
index 00000000..a31189ea
--- /dev/null
+++ b/extra/python-beaker/PKGBUILD
@@ -0,0 +1,12 @@
+checkdepends=(
+ $(
+ printf '%s\n' "${checkdepends[@]}" | \
+ grep -vxF 'mongodb'
+ )
+)
+eval "$(
+ declare -f check | \
+ sed '
+ s/ pifpaf run mongodb \([^-]\S* \+\|--\S\+ \+\)*--//
+ '
+)"