summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-21 10:00:59 +0100
committerErich Eckner <git@eckner.net>2019-01-21 10:00:59 +0100
commitc6eefb3bfcbdd5eff91a79f309d1c7512da148ee (patch)
treec9313dea2f591c6b50cdcd706902ec826d7d1768
parent3c6574f7ca67c5167f6ba35f0318f76ef72f1779 (diff)
parent6128197682f03bec73f8eba04df2d7114caf54cc (diff)
downloadpackages-c6eefb3bfcbdd5eff91a79f309d1c7512da148ee.tar.xz
Merge branch 'master' into i486
-rw-r--r--extra/hwloc/PKGBUILD5
-rw-r--r--extra/linux-pae/PKGBUILD6
-rw-r--r--extra/linux-pae/config4
3 files changed, 10 insertions, 5 deletions
diff --git a/extra/hwloc/PKGBUILD b/extra/hwloc/PKGBUILD
new file mode 100644
index 00000000..f271a407
--- /dev/null
+++ b/extra/hwloc/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no cairo
+ makedepends=(${makedepends[@]//cairo/})
+fi
diff --git a/extra/linux-pae/PKGBUILD b/extra/linux-pae/PKGBUILD
index a067b90e..85a3840a 100644
--- a/extra/linux-pae/PKGBUILD
+++ b/extra/linux-pae/PKGBUILD
@@ -4,7 +4,7 @@
# Maintainer: Thomas Baechler <thomas@archlinux.org>
pkgbase=linux-pae # Build stock -ARCH kernel
-pkgver='4.18.12'
+pkgver='4.18.13'
_srcname=linux-${pkgver}
pkgrel='1'
arch=('i686')
@@ -24,9 +24,9 @@ validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-sha256sums=('846a5ad9cbe576f66aeeb188c9bd45d14eee0783aebfc4ea853dac09a7159fc5'
+sha256sums=('dc87a1c6b591cff9034197cdefafb74ee9e0a507fa1a0a1fde823fa99e389650'
'SKIP'
- 'e8884986b8b50a560ba6b4be383955b97c98e4cb148aa2bc2387a4869e020bb3'
+ '22c4f7797faf6d39c27e03225d715397f9b41ebe4b19486d44704d5d15d5acd9'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
diff --git a/extra/linux-pae/config b/extra/linux-pae/config
index 6df3f170..acaa82d1 100644
--- a/extra/linux-pae/config
+++ b/extra/linux-pae/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.18.11-1 Kernel Configuration
+# Linux/x86 4.18.13-1 Kernel Configuration
#
#
@@ -1330,8 +1330,8 @@ CONFIG_NF_LOG_ARP=m
CONFIG_NF_LOG_IPV4=m
CONFIG_NF_REJECT_IPV4=m
CONFIG_NF_NAT_IPV4=m
-CONFIG_NFT_CHAIN_NAT_IPV4=m
CONFIG_NF_NAT_MASQUERADE_IPV4=y
+CONFIG_NFT_CHAIN_NAT_IPV4=m
CONFIG_NFT_MASQ_IPV4=m
CONFIG_NFT_REDIR_IPV4=m
CONFIG_NF_NAT_SNMP_BASIC=m