summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-21 10:10:30 +0100
committerErich Eckner <git@eckner.net>2019-01-21 10:10:30 +0100
commit44997e9d4fe44e6c7c4a55556d888ae1d9a94fc5 (patch)
treed567725073108ad43ad984ac3e8bbdafd59de0e4
parent110c12613a8ad230c4afb0e699a1e835f1dab6d0 (diff)
parentbb161a0de693802cdcec8d1b06c90b7450b39932 (diff)
downloadpackages-44997e9d4fe44e6c7c4a55556d888ae1d9a94fc5.tar.xz
Merge branch 'master' into i486
-rw-r--r--blacklist2
-rw-r--r--community/dtc/PKGBUILD3
-rw-r--r--community/electron/PKGBUILD2
-rw-r--r--community/electron2/PKGBUILD2
-rw-r--r--community/netcdf-openmpi/PKGBUILD11
-rw-r--r--community/netcdf/PKGBUILD7
-rw-r--r--community/openipmi/PKGBUILD2
-rw-r--r--extra/archiso/PKGBUILD2
8 files changed, 28 insertions, 3 deletions
diff --git a/blacklist b/blacklist
index ec3160a4..2c800fd0 100644
--- a/blacklist
+++ b/blacklist
@@ -11,6 +11,7 @@ i686 libretro-citra # do not build, see FS32#23
i686 libretro-mupen64plus # do not build, see FS32#23
i686 libretro-parallel-n64 # do not build, see FS32#23
i686 libretro-ppsspp # do not build, see FS32#23
+i686 libretro-desmume # do not build, see FS32#23
i686 luxrays # does not compile on i686 - see FS#54960
i686 mongodb # dropped support for 32-bit in version 3.4
i686 nginx-mod-pagespeed # bundles a 64-bit only version of psol, doesn't build that way
@@ -24,6 +25,7 @@ i686 ospray # "Your Embree build needs to support at least one ISA >= SSE4.1!"
any ovmf # "ERROR: This package must be built under the x86_64 architecture.", UEFI for VMS, of little use anyway with 32-bit machines
i686 parallel-netcdf-openmpi # requires MPI_Offset >= 8, which is not (yet?) possible on 32 bits - see https://github.com/open-mpi/ompi/issues/3195
i686 parity # "32-bit targets are not supported at the moment, You can use '32bit_opt_in' feature. See https://github.com/pepyakin/wasmi/issues/43
+any pnetcdf-openmpi # "Building of PnetCDF cannot continue due to the size of MPI_Offset being less than 8 bytes. Please use an MPI library that supports large files. Abort."
i686 python-openstacksdk # infinite looping on build slaves, might be temporary
i686 python-pytorch # Gloo can only be built on 64-bit systems
i686 qcef # contains CEF binaries (not current ones) for 64-bit and MIPS only, no 32-bit Intel. Discuss with the authors if you need it.
diff --git a/community/dtc/PKGBUILD b/community/dtc/PKGBUILD
new file mode 100644
index 00000000..d97cb9a7
--- /dev/null
+++ b/community/dtc/PKGBUILD
@@ -0,0 +1,3 @@
+# revert commit 1799ef5ac2fba01a19e89b5bef23315a7570624b
+source+=('fix32bit.patch::https://github.com/dgibson/dtc/commit/f8872e29ce06d78d3db71b3ab26a7465fc8a9586.patch')
+sha256sums+=('e92bfc787b65e2610528d5c499835c083c1672455fc7998d202b7c986d5c5f1d')
diff --git a/community/electron/PKGBUILD b/community/electron/PKGBUILD
index 395d76f9..3446fe23 100644
--- a/community/electron/PKGBUILD
+++ b/community/electron/PKGBUILD
@@ -10,7 +10,7 @@ eval "$(
'
declare -f build | \
sed '
- \,^\s*script/bootstrap.py , s/py/py --target_arch=ia32/
+ s,^\s*script/bootstrap.py ,\0--target_arch=ia32 ,
s/-t x64/-t ia32/g
'
)"
diff --git a/community/electron2/PKGBUILD b/community/electron2/PKGBUILD
index 4f1a6f90..3446fe23 100644
--- a/community/electron2/PKGBUILD
+++ b/community/electron2/PKGBUILD
@@ -10,7 +10,7 @@ eval "$(
'
declare -f build | \
sed '
- s,/bootstrap.py ,\0--target_arch=ia32 ,
+ s,^\s*script/bootstrap.py ,\0--target_arch=ia32 ,
s/-t x64/-t ia32/g
'
)"
diff --git a/community/netcdf-openmpi/PKGBUILD b/community/netcdf-openmpi/PKGBUILD
new file mode 100644
index 00000000..e18dbf41
--- /dev/null
+++ b/community/netcdf-openmpi/PKGBUILD
@@ -0,0 +1,11 @@
+# breaking a cycle with pnetcdf-openmpi
+depends=(${depends[@]//"pnetcdf-${_mpi}"/})
+
+# "Unable to support CDF5 feature because size_t is less than 8 bytes"
+eval "$(
+ declare -f build | \
+ sed '
+ s/-DENABLE_CDF5=ON/-DENABLE_CDF5=OFF/g
+ s/-DENABLE_PNETCDF=ON/-DENABLE_PNETCDF=OFF/g
+ '
+)"
diff --git a/community/netcdf/PKGBUILD b/community/netcdf/PKGBUILD
new file mode 100644
index 00000000..69f8f47a
--- /dev/null
+++ b/community/netcdf/PKGBUILD
@@ -0,0 +1,7 @@
+# "Unable to support CDF5 feature because size_t is less than 8 bytes"
+eval "$(
+ declare -f build | \
+ sed '
+ s/-DENABLE_CDF5=ON/-DENABLE_CDF5=OFF/g
+ '
+)"
diff --git a/community/openipmi/PKGBUILD b/community/openipmi/PKGBUILD
new file mode 100644
index 00000000..46c10e69
--- /dev/null
+++ b/community/openipmi/PKGBUILD
@@ -0,0 +1,2 @@
+# see FS#61289
+depends+=(libedit)
diff --git a/extra/archiso/PKGBUILD b/extra/archiso/PKGBUILD
index cb86e4f5..d11c1a00 100644
--- a/extra/archiso/PKGBUILD
+++ b/extra/archiso/PKGBUILD
@@ -4,7 +4,7 @@ license=('GPL')
url='https://git.archlinux32.org/archlinux32/archiso32'
source=("https://sources.archlinux32.org/sources/${pkgname}32-i686-v${pkgver}.tar.gz"{,.sig})
unset sha256sums
-sha512sums=('0c5d4b1c033eadbc63801b501ef24406bd1e77e7157a2abf9b3990d79563fde5c8f3cd3999a070d07625f7c20f6e46daa9190cd0f097de98afa0e61fc8eca25e'
+sha512sums=('abefe4cce52ad279a2d0377dded4cee9dbb3c8a675bd18096a20749df62899c4bd3d364a15f0dfaf76640a728abb77d96e413c567b9cf8c9fd9d0c94b9c6c396'
'SKIP')
validpgpkeys=('DE9F7688CACF04FEB81A6C590AEEC90755DA7B5A')