summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-21 10:10:49 +0100
committerErich Eckner <git@eckner.net>2019-01-21 10:10:49 +0100
commit38f945d190be4e07b1613a42536b85b513658006 (patch)
treee7841aef6f537e12ac22ae631dea78bd5139ef14
parent44997e9d4fe44e6c7c4a55556d888ae1d9a94fc5 (diff)
parentc82f1064549c938d8d64dd434ceeff228f0fa4fb (diff)
downloadpackages-38f945d190be4e07b1613a42536b85b513658006.tar.xz
Merge branch 'master' into i486
-rw-r--r--community/pypy/PKGBUILD5
-rw-r--r--core/archlinux32-keyring-transition/PKGBUILD5
-rw-r--r--core/archlinux32-keyring/PKGBUILD4
-rw-r--r--core/pacman/PKGBUILD6
-rw-r--r--core/pacman/makepkg.conf4
-rw-r--r--extra/conky/PKGBUILD8
-rw-r--r--extra/conky/fix-type-mismatch.patch13
-rw-r--r--extra/linux-pae/PKGBUILD6
-rw-r--r--extra/linux-pae/config4
9 files changed, 41 insertions, 14 deletions
diff --git a/community/pypy/PKGBUILD b/community/pypy/PKGBUILD
new file mode 100644
index 00000000..e7388a20
--- /dev/null
+++ b/community/pypy/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # testing deterministically kills build slaves..
+ unset check
+fi
diff --git a/core/archlinux32-keyring-transition/PKGBUILD b/core/archlinux32-keyring-transition/PKGBUILD
index 2293f4cb..2f064115 100644
--- a/core/archlinux32-keyring-transition/PKGBUILD
+++ b/core/archlinux32-keyring-transition/PKGBUILD
@@ -1,7 +1,8 @@
+# Maintainer: Eli Schwartz <eschwartz@archlinux.org>
# Maintainer: Erich Eckner <deep42thought@archlinux32.org>
pkgname=archlinux32-keyring-transition
_pkgname=${pkgname%-*}
-pkgver=20180603
+pkgver=20190108
pkgrel=1
pkgdesc='Arch Linux 32 PGP keyring - transition package'
arch=('any')
@@ -10,7 +11,7 @@ license=('GPL')
provides=('archlinux32-keyring')
install="${pkgname}.install"
source=("https://sources.archlinux32.org/sources/${_pkgname}-v${pkgver}.tar.gz"{,.sig})
-sha512sums=('74f92707d259657d21ddd4606c391f7efb358e14851fee980ac95418685b3a6098794400bbf46f681d010463ff186655885de6a9943ed51e1d6e7bbe31191f24'
+sha512sums=('8332d4634c543106eb0baeafedb3304bb4d43430a62260a551dbd76849fb2271d00dc0d6dfc73c2e276a0e9cc51f07e2ddf74c780f6dc4b135d2ab193afa520d'
'SKIP')
validpgpkeys=('DE9F7688CACF04FEB81A6C590AEEC90755DA7B5A') # Erich Eckner (replaces 0xC6A88E21) <erich@eckner.net>
diff --git a/core/archlinux32-keyring/PKGBUILD b/core/archlinux32-keyring/PKGBUILD
index d7b1add7..c831e66e 100644
--- a/core/archlinux32-keyring/PKGBUILD
+++ b/core/archlinux32-keyring/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Erich Eckner <deep42thought@archlinux32.org>
pkgname=archlinux32-keyring
-pkgver=20180603
+pkgver=20190108
pkgrel=1
pkgdesc='Arch Linux 32 PGP keyring'
arch=('any')
@@ -11,7 +11,7 @@ conflicts=('archlinux32-keyring-transition')
replaces=('archlinux32-keyring-transition')
source=("https://sources.archlinux32.org/sources/${pkgname}-v${pkgver}.tar.gz"{,.sig})
sha512sums=(
- '74f92707d259657d21ddd4606c391f7efb358e14851fee980ac95418685b3a6098794400bbf46f681d010463ff186655885de6a9943ed51e1d6e7bbe31191f24'
+ '8332d4634c543106eb0baeafedb3304bb4d43430a62260a551dbd76849fb2271d00dc0d6dfc73c2e276a0e9cc51f07e2ddf74c780f6dc4b135d2ab193afa520d'
'SKIP'
)
validpgpkeys=('DE9F7688CACF04FEB81A6C590AEEC90755DA7B5A')
diff --git a/core/pacman/PKGBUILD b/core/pacman/PKGBUILD
index 86372fc6..ce92903a 100644
--- a/core/pacman/PKGBUILD
+++ b/core/pacman/PKGBUILD
@@ -1,4 +1,4 @@
-# upstream git revision: e06c0338abc7919fe18a2070704bcd498344b29e
+# upstream git revision: 2519f7ad3a9ad47ee6bb997d53a2266ca34fdd52
depends+=(archlinux32-keyring)
@@ -7,8 +7,8 @@ for ((i=0; i<${#sha256sums[@]}; i++)); do
if [ "${sha256sums[${i}]}" = 'b82e9c1073292766c2f49b5c771dddf37383f1151117ef9cd5e0c11047b4f3eb' ]; then
sha256sums[${i}]='d75bbbe42d290c4f22a95e6ac86d4723dc6d0c08228d14c3dcbae9dc5d2514e5'
fi
- if [ "${sha256sums[${i}]}" = '650ddad24cad6afc4aecb4829cb8f06b9acb70c10a44f756fe8bd279949b518e' ]; then
- sha256sums[${i}]='d1c3e5f9b7259e401ab121aff335531452d23dc67d9e6c2f464771d25f11058a'
+ if [ "${sha256sums[${i}]}" = '8442bbb3d1d83f09610e9d687f9121037d97c6acaa06c4e907fc6e9eb0b127ec' ]; then
+ sha256sums[${i}]='730b6d399dc03ea0ea505fde9387b3fd14475a0e5421e53be30b6b2f946b974f'
fi
done
diff --git a/core/pacman/makepkg.conf b/core/pacman/makepkg.conf
index b1f1c25d..0b49df35 100644
--- a/core/pacman/makepkg.conf
+++ b/core/pacman/makepkg.conf
@@ -37,8 +37,8 @@ CHOST="i686-pc-linux-gnu"
#-- Compiler and Linker Flags
CPPFLAGS="-D_FORTIFY_SOURCE=2"
-CFLAGS="-march=i686 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt"
-CXXFLAGS="-march=i686 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt"
+CFLAGS="-march=i686 -mtune=generic -O2 -pipe -fno-plt"
+CXXFLAGS="-march=i686 -mtune=generic -O2 -pipe -fno-plt"
LDFLAGS="-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now"
#-- Make Flags: change this for DistCC/SMP systems
#MAKEFLAGS="-j2"
diff --git a/extra/conky/PKGBUILD b/extra/conky/PKGBUILD
new file mode 100644
index 00000000..506fad26
--- /dev/null
+++ b/extra/conky/PKGBUILD
@@ -0,0 +1,8 @@
+#see https://github.com/brndnmtthws/conky/issues/759
+sha256sums+=('842a3377b1d4fcaff8ec409b68fe6b05a9faf500f29b4d8e21cec3b4cd5b7da2')
+source+=('fix-type-mismatch.patch')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 -i "${srcdir}/fix-type-mismatch.patch"
+}
diff --git a/extra/conky/fix-type-mismatch.patch b/extra/conky/fix-type-mismatch.patch
new file mode 100644
index 00000000..a84d05e2
--- /dev/null
+++ b/extra/conky/fix-type-mismatch.patch
@@ -0,0 +1,13 @@
+diff --git a/src/linux.cc b/src/linux.cc
+index 0a7d4331..09fa6c99 100644
+--- a/src/linux.cc
++++ b/src/linux.cc
+@@ -1169,7 +1169,7 @@ static int open_sysfs_sensor(const char *dir, const char *dev, const char *type,
+ fd = open(path, O_RDONLY);
+ if (fd < 0) {
+ /* if it fails, strip the /device from dev and attempt again */
+- size_t len_to_trunc = std::max(7UL, strnlen(buf, 255)) - 7;
++ size_t len_to_trunc = std::max((size_t)7UL, strnlen(buf, 255)) - 7;
+ buf[len_to_trunc] = 0;
+ snprintf(path, 255, "%s%s/%s%d_input", dir, dev, type, n);
+ fd = open(path, O_RDONLY);
diff --git a/extra/linux-pae/PKGBUILD b/extra/linux-pae/PKGBUILD
index 98cd61a9..2fc41268 100644
--- a/extra/linux-pae/PKGBUILD
+++ b/extra/linux-pae/PKGBUILD
@@ -4,7 +4,7 @@
# Maintainer: Thomas Baechler <thomas@archlinux.org>
pkgbase=linux-pae # Build stock -ARCH kernel
-pkgver='4.20'
+pkgver='4.20.1'
_srcname=linux-${pkgver}
pkgrel='1'
arch=('i686')
@@ -24,9 +24,9 @@ validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-sha256sums=('ad0823183522e743972382df0aa08fb5ae3077f662b125f1e599b0b2aaa12438'
+sha256sums=('45096f1ffbfbb4cdeef6eecfa6ca7eabbf534f04645fd0d849564a58ddd2198f'
'SKIP'
- 'bc31046541799e3d0a916894ca4fb7bba387f582a37216e98345c095f8f5ee43'
+ 'b5f3d1a14dce62f52c6cf4efb67751cc6080515b2c969912f724e280b9b78060'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
diff --git a/extra/linux-pae/config b/extra/linux-pae/config
index 9175b3c3..e09adaad 100644
--- a/extra/linux-pae/config
+++ b/extra/linux-pae/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.20.0-1 Kernel Configuration
+# Linux/x86 4.20.1-1 Kernel Configuration
#
#
@@ -7277,10 +7277,10 @@ CONFIG_TYPEC_MUX_PI3USB30532=m
# USB Type-C Alternate Mode drivers
#
CONFIG_TYPEC_DP_ALTMODE=m
+CONFIG_USB_ROLE_SWITCH=m
CONFIG_USB_ROLES_INTEL_XHCI=m
CONFIG_USB_LED_TRIG=y
CONFIG_USB_ULPI_BUS=m
-CONFIG_USB_ROLE_SWITCH=m
CONFIG_UWB=m
CONFIG_UWB_HWA=m
CONFIG_UWB_WHCI=m