summaryrefslogtreecommitdiff
path: root/station_cmd.c
AgeCommit message (Collapse)Author
2007-01-02(svn r7759) -Merge: makefile rewrite. This merge features:rubidium
- A proper ./configure, so everything needs to be configured only once, not for every make. - Usage of makedepend when available. This greatly reduces the time needed for generating the dependencies. - A generator for all project files. There is a single file with sources, which is used to generate Makefiles and the project files for MSVC. - Proper support for OSX universal binaries. - Object files for non-MSVC compiles are also placed in separate directories, making is faster to switch between debug and release compiles and it does not touch the directory with the source files. - Functionality to make a bundle of all needed files for for example a nightly or distribution of a binary with all needed GRFs and language files. Note: as this merge moves almost all files, it is recommended to make a backup of your working copy before updating your working copy.
2006-12-28(svn r7599) -Fix: (r7585, r7590) assert on load game that has some station ↵KUDr
with bigger spread-out than _patches.station_spread value (Celestar)
2006-12-28(svn r7590) -Codechange: (r7585)KUDr
- use existing struct Rect instead of declaring new StationRect - use inline functions instead of macros
2006-12-27(svn r7585) -Codechange: CheckStationSpreadOut() took too much CPU. Station ↵KUDr
rectangle is now maintained instead of calculating it each time by walking through whole map. Should help with the performance issue related to AIs trying to build road stops too often. (idea by Celestar)
2006-12-27(svn r7573) -Merged the bridge branch. Allows to build bridges of arbitrary ↵celestar
rail/road combinations (including signals)
2006-12-26(svn r7565) -Codechange: Rework DEBUG functionality. Look for appropiate ↵Darkvater
debugging levels to use in debug.h. grfmsg() is now used as a specific debug-function for grf.
2006-12-22(svn r7547) -Fix: The cost of rail station removal was calculated based on ↵KUDr
the area occupied by the station. This produced unreasonably large removal costs for non-uniform stations. Now it is based on number of station tiles actually removed.
2006-12-05(svn r7372) - CodeChange: Rename all GetXXXArraySize() functions to ↵matthijs
GetNumXXX() and add GetMaxXXXIndex() functions. This prepares for the new pool interface.
2006-12-03(svn r7335) -Codechange: redraw station tiles when cargo is moved, for ↵peter1138
newstations
2006-12-03(svn r7331) - Codechange: Rename all memory pool macro's and types to "old ↵matthijs
pool", so the new pool implementation can be committed alongside it. - Codechange: Rename pool.[ch] to oldpool.[ch].
2006-11-17(svn r7195) -Feature: [FS#297, optional elrails] New patches/vehicles option ↵KUDr
'disable electrified railways'. (original patch by maedhros, ideas: peter1138, Darkvater, Rubidium, Patrick, Eddi|zuHause, ..)
2006-11-16(svn r7174) -CodeChange: CheckStationSpreadOut() now uses MergePoint() for ↵KUDr
bounding rectangle calculation.
2006-11-16(svn r7169) -Fix: [FS#388] Station sign (and base station coordinates) ↵KUDr
didn't move along with station when station moved by walking. (HMage)
2006-10-28(svn r6985) Remove stuff forgotten in r6984tron
2006-10-28(svn r6984) Use the pool macros for the RoadStop pooltron
2006-10-28(svn r6983) Use the pool macros for the Station pooltron
2006-10-21(svn r6881) -Fix r6874: uint > int to remove signedness warning MSVC (peter1138)Darkvater
2006-10-21(svn r6874) - [NewStations] Mark all tiles of a railway station dirty when ↵peter1138
adding or removing tiles.
2006-10-18(svn r6823) - Codechange: Ignore bit 0 of a NewStation custom tile callback ↵peter1138
result. This fixes cosmetic problems with some add on stations.
2006-10-17(svn r6803) -Codechange: Substitute magic numbers by an enum for the news ↵Darkvater
windows
2006-10-14(svn r6776) -Codechange: Use IsValidPlayer() function to determine of a ↵Darkvater
PlayerID is an actual playable player (< MAX_PLAYERS) or not.
2006-10-14(svn r6774) -Codechange: Rename the badly named OWNER_SPECTATOR to ↵Darkvater
PLAYER_SPECTATOR and put it into player.h where it belongs (instead of map.h)
2006-09-26(svn r6513) -Codechange: unified the code to draw depot windowsbjarni
This change is intended to make it easier to make depot behaviour consistent and faster to code when adding more features in the future The user interface should hopefully not be affected by this
2006-09-18(svn r6477) - Fix a loop-hole that allowed docks to be built regardless of ↵peter1138
town authority rating.
2006-09-05(svn r6406) -Codechange: Rename TileOffsByDir to TileOffsByDiagDir because ↵Darkvater
it accepts DiagDirections, and add TileOffsByDir that handles Directions. -Codechange: Make the treeloop use TileOffsByDir().
2006-09-04(svn r6381) -Cleanup: make the '/* */' comments that span multiple lines ↵rubidium
more uniform. -Cleanup: whitespace alignment of a few tables.
2006-09-03(svn r6355) -Fix: Go to hangar orders for aircraft could get spuriously ↵tron
removed when a road or rail depot got deleted (Darkvater and me) This bug is probably ages old
2006-09-03(svn r6353) -Codechange: Make DestinationID a typedef of uin16, which is as ↵tron
large as any type of destinataion (StationID, DepotID, WaypointID) it can hold DestinationID being a union of these types is just hassle without benefit and cannot be handled correctly everywhere because of local lack of information
2006-08-31(svn r6252) Replace a comglomerate of ifs for animated station tiles by a ↵tron
small table and a loop iterating over it
2006-08-28(svn r6204) -Cleanup: replace non-indentation with spaces; like '}<TAB>else ↵rubidium
{' -> '} else {', tabs between code and comment, etc.
2006-08-26(svn r6152) -Codechange: renamed GetNumRoadStops to GetNumRoadStopsInStation ↵truelight
as it reflects its function more
2006-08-26(svn r6151) -Codechange: DeleteStation/DeleteRoadStop removes a ↵truelight
station/RoadStop from the pool -Codechange: DestroyStation/DestroyRoadStop is called by DeleteStation/DeleteRoadStop to remove all things where a station/RoadStop depends on. Last 2 changes to prepare for new pool system. Not pretty now, will be soon.
2006-08-26(svn r6150) -Codechange: introduced and used RoadStopID where neededtruelight
2006-08-26(svn r6146) -Fix: MSVC doesn't know how to cast to an union.. so fix it via ↵truelight
an indirect (and btw the old) way
2006-08-26(svn r6142) -Codechange: added WaypointID (sorry DV, couldn't splits it anymore)truelight
-Codechange: introduced DestinationID, which is in fact an union of several types Used in Order struct, so no longer StationID is abused for all targets. Hangars are a big exception, as they use a station-id with GOTO_DEPOT (go figure)
2006-08-22(svn r6055) -Codechange: added GetXXXArraySize, which returns HighestID + 1 ↵truelight
(or, will do that). It isn't the best name, but we couldn't find any better. This unifies the pool-system even more.
2006-08-22(svn r6053) -Codechange: renamed all IsXXXIndex to IsValidXXXIDtruelight
-Codechange: IsValidXXXID now also checks if XXX is really valid, not if the number is within range Both changes again in preperation of the new mem-pool system, which requires this. IsValidXXXID is not a bit less pretty, but that will be cleaned up after the new mem-pool system
2006-08-22(svn r6052) -Codechange: change OrderType (order->type) in a typedeftruelight
-Codechange: renamed DeleteDestinationFromVehicleOrder to RemoveOrderFromAllVehicles to reflect his function better -Codechange: changed the params of RemoveOrderFromAllVehicles, to avoid unneeded variable-creation
2006-08-22(svn r6049) -Codechange: forgot EngineRenew in r6047truelight
-Codechange: cleaned up the EngineRenew code a bit (coding style mostly) -Codechange: forgot the correct comment in station_cmd -Codechange: move pool-stuff to engine.h, like we always do
2006-08-22(svn r6047) -Codechange: FOR_ALL now _only_ loops valid items, and skips ↵truelight
invalid ones -Codechange: use IsValidXXX where ever possible Note: both changes to prepare for new pool system, which needs those changes. For every pool there are 2 ugly lines, which will be removed when done implementing new pool system. Based on FS#13 by blathijs, partly implemented.
2006-08-22(svn r6045) -Cleanup: align all table-like structures using spaces, i.e. ↵rubidium
whitespace fixes only except for a few comments to make them uniform for the whole enum/struct.
2006-08-20(svn r5999) -Feature: change the original date format to a 32 bits format ↵rubidium
based at the year 0. The game date subsystem now allows someone to start in the year 0 and continue up to the year 5 000 000. However, you currently cannot build anything before 1920 as there is no newgrf support for dates before 1920 or after 2090 yet.
2006-08-14(svn r5887) -Cleanup: move date related functions, defines and variables to ↵rubidium
date.[ch] -Cleanup: fix whitespace related coding style issues in date.[ch] -Cleanup: make original comments doxygen compatible and remove/change outdated comments
2006-08-06(svn r5794) Pass the TileIndex plus x and y coordinates into GetSlopeZ_* ↵tron
instead of a TileInfo
2006-08-06(svn r5787) Rename width, height and unk of struct DrawTileSeqStruct to ↵tron
size_{x,y,z}
2006-08-05(svn r5773) Clarify why the owner is checked before a palette is chosen when ↵tron
drawing a station tile: some stations are not owned by players
2006-07-26(svn r5615) Move GetStationTileForVehicle() to its only usertron
2006-07-22(svn r5582) Add and use AxisToTrack{Bits,}()tron
2006-06-27(svn r5391) Miscellaneous, mostly bracing and whitespace, nothing spectaculartron
2006-06-25(svn r5362) - Fix: Updated sprites in New Airports to be allow cleaner ↵richk
replacement by newgrf graphics. All tiles now use SPR_AIRPORT_APRON as the tarmac. Created two new sprites in airports.grf for half-grass half-tarmac tiles on Intercontinental airport.