Age | Commit message (Collapse) | Author |
|
- A proper ./configure, so everything needs to be configured only once, not for every make.
- Usage of makedepend when available. This greatly reduces the time needed for generating the dependencies.
- A generator for all project files. There is a single file with sources, which is used to generate Makefiles and the project files for MSVC.
- Proper support for OSX universal binaries.
- Object files for non-MSVC compiles are also placed in separate directories, making is faster to switch between debug and release compiles and it does not touch the directory with the source files.
- Functionality to make a bundle of all needed files for for example a nightly or distribution of a binary with all needed GRFs and language files.
Note: as this merge moves almost all files, it is recommended to make a backup of your working copy before updating your working copy.
|
|
r4911)
|
|
rail/road combinations (including signals)
|
|
GetNumXXX() and add GetMaxXXXIndex() functions. This prepares for the new pool interface.
|
|
|
|
(currently max speed * capacity) instead of either the cost or the index of the vheicle.
|
|
stop/depot (peter1138)
|
|
cargo type in favour of just checking the cargo type of each vehicle.
|
|
because FOR_ALL_STATIONS skips invalid stations
|
|
IS_INTERACTIVE_PLAYER
|
|
of DoCommandP
with a boolean type.
|
|
it accepts
DiagDirections, and add TileOffsByDir that handles Directions.
-Codechange: Make the treeloop use TileOffsByDir().
|
|
large as any type of destinataion (StationID, DepotID, WaypointID) it can hold
DestinationID being a union of these types is just hassle without benefit and cannot be handled correctly everywhere because of local lack of information
|
|
CMD_SEND_TRAIN_TO_DEPOT instead of CMD_TRAIN_GOTO_DEPOT
|
|
{' -> '} else {', tabs between code and comment, etc.
|
|
-Codechange: introduced DestinationID, which is in fact an union of several types
Used in Order struct, so no longer StationID is abused for all targets.
Hangars are a big exception, as they use a station-id with GOTO_DEPOT (go figure)
|
|
a valid XXX, unless there are none to pick from. Then NULL is returned.
|
|
(or, will do that).
It isn't the best name, but we couldn't find any better.
This unifies the pool-system even more.
|
|
invalid ones
-Codechange: use IsValidXXX where ever possible
Note: both changes to prepare for new pool system, which needs those changes.
For every pool there are 2 ugly lines, which will be removed when done
implementing new pool system.
Based on FS#13 by blathijs, partly implemented.
|
|
whitespace fixes only except for a few comments to make them uniform for the whole enum/struct.
|
|
|
|
functions really depend on the original date format.
-Cleanup: use DAYS_TILL_ORIGINAL_BASE_YEAR where the date variables are in the old date format and conversions are needed.
-Cleanup: replace one (forgotten) instance of uint16 with Date.
|
|
date.[ch]
-Cleanup: fix whitespace related coding style issues in date.[ch]
-Cleanup: make original comments doxygen compatible and remove/change outdated comments
|
|
|
|
of magical engine numbers
|
|
|
|
replacing some magic numbers by enums
|
|
scope, CSE for readability, DeMorgan, if cascades -> switch, whitespace, parentheses, bracing, misc.
|
|
|
|
coded numbers instead of enums to calculate prices
|
|
|
|
|
|
_new_vehicle_id is enough.
|
|
-Feature: Bridges can now be placed above:
Any railway track combination (excluding depots and waypoints)
Any road combination (excluding depots)
Clear tiles (duh), including fields
Tunnel entrances
Bridge heads
Thanks to Tron for idea and implementation, KUDr for the yapf synchronization and many others for hours of testing
There are still a number of visual problems remaining, especially when electric railways are on or under the bridge.
DO NOT REPORT THOSE BUGS FOR THE TIME BEING please.
|
|
array into the struct which describes an airport
|
|
bridges.
NOTE 1: Remove/revert this for the bridge branch
NOTE 2: Bug displays fundamental flaw in command system:
If two commands, where command 2 depends on command 1, have
to be checked, all those checks need to be manual.
(like in this example, first build rail then build signal.
BuildSignal cannot be checked without DC_EXEC as the rail
isn't there yet)
|
|
ROAD_{NORMAL,CROSSING,DEPOT} to ROAD_TILE_* for consistency
|
|
RAIL_TYPE_{NORMAL,SIGNAL,...} have nearly the same name, rename RAIL_TYPE_* to RAIL_TILE_* of extra clarity
|
|
|
|
|
|
coordinates of the tile to operate on - to a TileIndex
Remove DoCommandByTile(), because now it does the same as DoCommand()
|
|
|
|
two drops ...
|
|
code and proofreading, thanks to peter1138 for another lot of code and ideas.
|
|
|
|
variables instead of using the general byte-type.
|
|
|
|
hangar _or_ not stopped, not when it's not in a hangar _and_ not stopped
|
|
station from a tile
|
|
|