summaryrefslogtreecommitdiff
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
new file mode 100644
index 000000000..96da08932
--- /dev/null
+++ b/src/core/CMakeLists.txt
@@ -0,0 +1,30 @@
+add_files(
+ alloc_func.cpp
+ alloc_func.hpp
+ alloc_type.hpp
+ backup_type.hpp
+ bitmath_func.cpp
+ bitmath_func.hpp
+ endian_func.hpp
+ endian_type.hpp
+ enum_type.hpp
+ geometry_func.cpp
+ geometry_func.hpp
+ geometry_type.hpp
+ kdtree.hpp
+ math_func.cpp
+ math_func.hpp
+ mem_func.hpp
+ multimap.hpp
+ overflowsafe_type.hpp
+ pool_func.cpp
+ pool_func.hpp
+ pool_type.hpp
+ random_func.cpp
+ random_func.hpp
+ smallmap_type.hpp
+ smallmatrix_type.hpp
+ smallstack_type.hpp
+ smallvec_type.hpp
+ string_compare_type.hpp
+)