summaryrefslogtreecommitdiff
path: root/src/video/CMakeLists.txt
diff options
context:
space:
mode:
authorPatric Stout <truebrain@openttd.org>2021-02-20 11:54:33 +0100
committerPatric Stout <github@truebrain.nl>2021-02-20 17:08:44 +0100
commit0e76d965f1d90af6318586ab5f5b7c6a87989c02 (patch)
tree8b27947809768d7be2b74661f80f7d53d79fe9e3 /src/video/CMakeLists.txt
parent7996fadb91b6ff9a8ca17791d03677ddb438fc07 (diff)
downloadopenttd-0e76d965f1d90af6318586ab5f5b7c6a87989c02.tar.xz
Codechange: deduplicate tick-handlers of all video drivers
They were all identical, so better put this in a single place hoping it is less likely to break.
Diffstat (limited to 'src/video/CMakeLists.txt')
-rw-r--r--src/video/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/video/CMakeLists.txt b/src/video/CMakeLists.txt
index a5d862e9b..02b65d4be 100644
--- a/src/video/CMakeLists.txt
+++ b/src/video/CMakeLists.txt
@@ -31,5 +31,6 @@ add_files(
dedicated_v.h
null_v.cpp
null_v.h
+ video_driver.cpp
video_driver.hpp
)