summaryrefslogtreecommitdiff
path: root/src/script/api/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Lutz <michi@icosahedron.de>2021-08-09 23:34:50 +0200
committerGitHub <noreply@github.com>2021-08-09 23:34:50 +0200
commit8706dcd9c1ac8f695b7a0cb1a204fb6bcbaa492f (patch)
tree8797cfea8ea6f51850e799ae4539d289a4f7548f /src/script/api/CMakeLists.txt
parentd58772ecdadb67cbd571ab46eb1c822c421da8c0 (diff)
downloadopenttd-8706dcd9c1ac8f695b7a0cb1a204fb6bcbaa492f.tar.xz
Add: [Script] Basic information about loaded NewGRFs for scripts. (#9464)
Currently, scripts use various heuristics to detect loaded NewGRFs that are inherently unreliable. The list of loaded NewGRFs is easily accessible to a human player, and thus giving scripts the same information is consistent with the current approach to not give scripts more information than a human player.
Diffstat (limited to 'src/script/api/CMakeLists.txt')
-rw-r--r--src/script/api/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/script/api/CMakeLists.txt b/src/script/api/CMakeLists.txt
index c21707d43..a6390e2bb 100644
--- a/src/script/api/CMakeLists.txt
+++ b/src/script/api/CMakeLists.txt
@@ -179,6 +179,7 @@ add_files(
script_log.hpp
script_map.hpp
script_marine.hpp
+ script_newgrf.hpp
script_news.hpp
script_object.hpp
script_order.hpp
@@ -246,6 +247,7 @@ add_files(
script_log.cpp
script_map.cpp
script_marine.cpp
+ script_newgrf.cpp
script_news.cpp
script_object.cpp
script_order.cpp